Unable create a sample project in meteor


#1

I created my first project in meteor, i just created it in command prompt and run. It shows error. I haven’t changed any code, even ddnt open the root directory in IDE.

This is the error message.

DELL@DELL-PC C:\Users\DELL\amsfyn

meteor
[[[[[ C:\Users\DELL\amsfyn ]]]]]

=> Started proxy.
=> Started MongoDB.
Errors prevented isopacket load:

While loading isopacket ddp:
module.js:338:15: Cannot find module './_baseClone’
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\DELL\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\isopackets\ddp\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-types\node_modules\lodash\clone.js:1:17)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load (C:\Users\DELL\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\DELL\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\isopackets\ddp\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-types\lib\index.js:314:38)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load (C:\Users\DELL\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\DELL\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\isopackets\ddp\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-template\lib\index.js:84:43)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load (C:\Users\DELL\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\DELL\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\isopackets\ddp\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\lib\index.js:525:46)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load (C:\Users\DELL\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module.load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
.extend.Npm.require (C:\tools\isobuild\bundler.js:1570:22)
at Object.require (C:\tools\isobuild\bundler.js:1547:11)
at Package (packages/babel-compiler/babel-compiler.js:17:1)
at packages/babel-compiler/babel-compiler.js:356:1
at packages/babel-compiler/babel-compiler.js:356:1

=> Errors prevented startup:

While loading plugin compile-ecmascript from package ecmascript:
module.js:338:15: Cannot find module './_baseClone’
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\DELL\AppData\Local.meteor\packages\ecmascript\0.4.4\plugin.compile-ecmascript.os\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-types\node_modules\lodash\clone.js:1:17)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load (C:\Users\DELL\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\DELL\AppData\Local.meteor\packages\ecmascript\0.4.4\plugin.compile-ecmascript.os\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-types\lib\index.js:314:38)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load (C:\Users\DELL\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\DELL\AppData\Local.meteor\packages\ecmascript\0.4.4\plugin.compile-ecmascript.os\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-template\lib\index.js:84:43)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load (C:\Users\DELL\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\DELL\AppData\Local.meteor\packages\ecmascript\0.4.4\plugin.compile-ecmascript.os\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\lib\index.js:525:46)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load (C:\Users\DELL\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module.load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
.extend.Npm.require (C:\tools\isobuild\bundler.js:1570:22)
at Object.require (C:\tools\isobuild\bundler.js:1547:11)
at Package (packages/babel-compiler/babel-compiler.js:17:1)
at packages/babel-compiler/babel-compiler.js:356:1
at packages/babel-compiler/babel-compiler.js:356:1

While loading plugin compileTemplatesBatch from package templating:
module.js:338:15: Cannot find module './_baseClone’
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\DELL\AppData\Local.meteor\packages\templating\1.1.10\plugin.compileTemplatesBatch.os\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-types\node_modules\lodash\clone.js:1:17)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load (C:\Users\DELL\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\DELL\AppData\Local.meteor\packages\templating\1.1.10\plugin.compileTemplatesBatch.os\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-types\lib\index.js:314:38)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load (C:\Users\DELL\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\DELL\AppData\Local.meteor\packages\templating\1.1.10\plugin.compileTemplatesBatch.os\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-template\lib\index.js:84:43)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load (C:\Users\DELL\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\DELL\AppData\Local.meteor\packages\templating\1.1.10\plugin.compileTemplatesBatch.os\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\lib\index.js:525:46)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load (C:\Users\DELL\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module.load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
.extend.Npm.require (C:\tools\isobuild\bundler.js:1570:22)
at Object.require (C:\tools\isobuild\bundler.js:1547:11)
at Package (packages/babel-compiler/babel-compiler.js:17:1)
at packages/babel-compiler/babel-compiler.js:356:1
at packages/babel-compiler/babel-compiler.js:356:1

=> Your application has errors. Waiting for file change.

Can anybody help me to fix this errors. and start a meteor & react project.


#2

What commands (in sequence) did you use to create and run your project?


#3

It shao that your app has errors. before i started writing any custom code.


#4

Did you do:

meteor create someproject
cd someproject
meteor npm install
meteor

#5

Yes. It gave me an output that your code has error. Now am installing meteor again.

Am on windows. is it a problem?


#6

It may be that your base Meteor installation and/or the runtime in your project folder is corrupt. There is an issue being tracked which may be related.

Do you always get the same error if you create new projects?

If yes, you should remove your Meteor installation and re-install. You can remove from Control Panel -> Programs and Features.

If no, just delete the faulty project and retry.


#7

I have nodejs and java installed on the system. before meteor install… is there any issue on this?


#8

Well, java’s not a problem.

nodejs should also be ok, because Meteor bundles known versions of nodejs and npm. You can do meteor node -v and meteor npm -v to confirm the bundled version numbers.

For example, on my system:

C:\Users\robfallows>meteor --version
Meteor 1.3.3

C:\Users\robfallows>meteor node -v
v0.10.43

C:\Users\robfallows>meteor npm -v
2.14.22

However, I also have different versions of node and npm installed:

C:\Users\robfallows>node -v
v5.3.0

C:\Users\robfallows>npm -v
2.11.2

I’m not seeing any issues running Meteor 1.3.3 (I’ve created projects as above, updated existing projects and created projects from repos). I am on Win7 - if that makes a difference.


#9

It looks like you’re not alone:


#10

FYI, this has been reported on as meteor issue #7221. It appears to be a Windows specific problem and happens with the most basic apps. I’d bet they are fast at work on 1.3.3.1.


#11

Had the same problem, if you have win 10 (pirate) go boot windows 7 :slight_smile: