Unable to deploy meteor(Meteor version app to amazon ec2

Migrated angular-meteor web app form meteor- to
After an upgrade, I am not able to deploy it on Amazon ec2 server.

Meteor with node 4.8.0 and npm 4.3.0.

Not sure IS this because of node version or it’s a meteor bug.

I am using Mup to deploy in ec2

Local it is running perfectly.

I need a fix as fast as possible.

mup is using your global node version. see if your global node version is the same that your meteor version needs and try again. (just a guess)

Also try to check your node version on the server since you upgraded you might have to run mup setup or reconfig again.

on another look try to increase deployment wait time since you deployment process seems to work.
dont know ;I

Still not able to deploy.

I made local machine node version to 4.8.0 which is a meteor app node version, still having the same issue.

I made deployment time 3x as earlier but no luck. even though I have created a new instance and installed the same version of mongo as the meteor is using in my local machine. stall no luck.

local - node 4.8.0
local - npm - 2.15.11
meteor app -node 4.8.0
meteor - npm - 4.3.0

I am not understanding whether it’s a problem of meteor or npm or node?

I am in hurry, please suggest, what to do next?

I don’t understand why you want to delete this.

It wasn’t very relevant I think.

Pls check the npm version. Should be above 3.

Modified tag from deployment to help.

No luck.
I tried with
local node 4.8.0
local npm 4.0.5
meteor node 4.8.0
meteor npm 4.3.0

Try to delete .meteor\local directory and restart meteor…

– Rajesh Bhaskar

Tried but did not work.

What is your mup version? “npm list mup” or “npm list -g mup”

BTW, version of node at your server also matters.

@perak Did not work.

I used
sudo npm -g install git+https://github.com/RockaLabs/meteor-up.git#muprockanew
and than
muprockanew setup and muprockanew deploy.
Worked for me.

should include in main branch also.

For more info

1 Like

Got the solution for mup deploy after migrating to meteor to

delate the docker image from docker container or delete container itself in ec2 instance because meteor 1.3 uses image: '‘kadirahq/meteord’.
Meteor 1.4 uses image: ‘abernix/meteord:base’,
in docker container so just mention in mup.js
docker {
image: '‘kadirahq/meteord’ // for meteor 1.3 //
image: ‘abernix/meteord:base’ // for moeter 1.4 //

1 Like