Unable to publish package to Atmosphere


I created a package and now I want to publish it to Atmosphere.

I run the command:
meteor publish --create

And I get the error message:

Problem! This project does not have a .meteor/release file. The file should either contain the release of Meteor that you want to use, or the word ‘none’ if you will only use the project with unreleased checkouts of Meteor. Please edit the .meteor/release file in the project and change it to a valid Meteor release or ‘none’.

Why am I getting this error? My package shouldn’t have a .meteor/release file should it?

No, it shouldn’t. Are you issuing the publish command within the directory containing your package?

Yes, I am.

When I run it in the main directory, I get:
publish: You're not in a Meteor package directory.

Do you have a package.js file (correctly constructed :wink:)?

It’s working with my Meteor project. And I’ve even tried doing:
meteor create --package username:package-name
and then running
meteor publish --create
straight after and that also doesn’t work.

Are you creating your package(s) in a directory independent of your app directory, or are you creating them in a packages directory in the root of your app?

In a packages dir in the root of the app.

I’ve created a new project and added my package to that. With this new project things are working.

Yeah - I think that’s confusing the package publisher.

Much better to have a completely separate folder structure for your packages and set the PACKAGE_DIRS environment variable while you’re developing. Then you can switch into the package folder when it’s time to publish without confusing things :smile:

Thanks. I’ll do that in the future. Still not sure why things are working with a blank app and not my main app.

Also, if I create an external packages directory, is there an easy way to still include it in the main git repo for the project? This is important for packages that aren’t on Atmosphere.

Also, having problems with adding package dir. Something not right with my set up.