Unable to use OpLogs in production

Hello everyone !

Meteor 2.0
Mongo@4.0.2 hosted at Mongo Atlas M10 cluster

I’m facing a huge pb : MONGO_OPLOG_URL works perfectly well when connecting to my Mongo Atlas database from my local computer, the app starts, oplog are used, everything is fine.

But from my production environment (a docker container hosted at CleverCloud), that have a working network access to the Atlas cluster and uses the exact same MONGO_URL & MONGO_OPLOG_URL than I use locally, I can’t start the app, as I get this error :

 MongoError: not authorized on local to execute command { insert: "system.indexes", documents: [ { ns: "local.users", key: { username: 1 }, name: "username_1", unique: true, sparse: true } ], ordered: true, writeConcern: { w: "majority" }, lsid: { id: UUID("fe6dca51-e974-42ef-8514-77f1eb9a6b86") }, $clusterTime: { clusterTime: Timestamp(1614095618, 152), signature: { hash: BinData(0, A6F8C7C6F422B9DB4D97C0D98F77B7D79C75C582), keyId: 6888396453450874882 } }, $db: "local" }

Mongo Atlas Support, after I shared that with them, simply told me this, that seems unrelevant in my case :

It looks like you are trying to access the db.system namespace.
Starting in MongoDB 4.2, <database>.system.indexes has been removed (access to the collection has been deprecated since 3.0). To list the indexes, use the listIndexes command instead.
 And then just proposed me to reach out to Meteor community ....

My Mongo env var URI uses the mongo+srv pattern, like so :



I need to enable this ASAP, as my latest update of the software is quite heavily relying on pub/sub

Any idea about this and how I could solve it ? :slightly_smiling_face:

Thank you all ! :wink: