Uncaught Error: Bootstrap's JavaScript requires at least jQuery v1.9.1 but less than v3.0.0


#1

I do have the following message in the console:

Uncaught Error: Bootstrap's JavaScript requires at least jQuery v1.9.1 but less than v3.0.0

In .meteor > version file it says it’s jquery@1.11.9.

  • I did tried to meteor remove and the install again both jquery and boostrap separately.
  • Also tried to manualy change current version in .meteor version file to 1.9.1 first in terminal it says:
    jquery upgraded from 1.9.1 to 1.11.9
    But after server restart the current version is back to 1.11.9

What can be done to retrieve the favor of the javascript gods?


#2

Add "jquery": "<3.0.0", to your package.json dependencies, delete node_modules directory And do meteor npm install


#3

Doesn’t this load two copies of jQuery? Isn’t that supposed to be bad juju?


#4

Might be you could try remove jquery meteor package :slight_smile: and just use jquery from npm package.