Unexpected token punc


#1

Maybe I made the mistake to upgrade to 1.3.2.4 too early, but trying to build my application now fails with this error. Should I downgrade?

Errors prevented bundling:                    
While minifying app code:                     
/Users/jhm/.meteor/packages/standard-minifier-js/.1.0.6.1ap68qh++os+web.browser+web.cordova/plugin.minifyStdJS.os/npm/node_modules/meteor/minifier-js/node_modules/uglify-js/lib/parse.js:196:18:
Unexpected token punc «(», expected punc «:»
at new JS_Parse_Error
(/Users/jhm/.meteor/packages/standard-minifier-js/.1.0.6.1ap68qh++os+web.browser+web.cordova/plugin.minifyStdJS.os/npm/node_modules/meteor/minifier-js/node_modules/uglify-js/lib/parse.js:196:18)
at js_error
(/Users/jhm/.meteor/packages/standard-minifier-js/.1.0.6.1ap68qh++os+web.browser+web.cordova/plugin.minifyStdJS.os/npm/node_modules/meteor/minifier-js/node_modules/uglify-js/lib/parse.js:204:11)
at croak
(/Users/jhm/.meteor/packages/standard-minifier-js/.1.0.6.1ap68qh++os+web.browser+web.cordova/plugin.minifyStdJS.os/npm/node_modules/meteor/minifier-js/node_modules/uglify-js/lib/parse.js:675:9)
at token_error
(/Users/jhm/.meteor/packages/standard-minifier-js/.1.0.6.1ap68qh++os+web.browser+web.cordova/plugin.minifyStdJS.os/npm/node_modules/meteor/minifier-js/node_modules/uglify-js/lib/parse.js:683:9)
at expect_token
(/Users/jhm/.meteor/packages/standard-minifier-js/.1.0.6.1ap68qh++os+web.browser+web.cordova/plugin.minifyStdJS.os/npm/node_modules/meteor/minifier-js/node_modules/uglify-js/lib/parse.js:696:9)
at expect
(/Users/jhm/.meteor/packages/standard-minifier-js/.1.0.6.1ap68qh++os+web.browser+web.cordova/plugin.minifyStdJS.os/npm/node_modules/meteor/minifier-js/node_modules/uglify-js/lib/parse.js:699:36)
at
/Users/jhm/.meteor/packages/standard-minifier-js/.1.0.6.1ap68qh++os+web.browser+web.cordova/plugin.minifyStdJS.os/npm/node_modules/meteor/minifier-js/node_modules/uglify-js/lib/parse.js:1252:13
at
/Users/jhm/.meteor/packages/standard-minifier-js/.1.0.6.1ap68qh++os+web.browser+web.cordova/plugin.minifyStdJS.os/npm/node_modules/meteor/minifier-js/node_modules/uglify-js/lib/parse.js:722:24
at expr_atom
(/Users/jhm/.meteor/packages/standard-minifier-js/.1.0.6.1ap68qh++os+web.browser+web.cordova/plugin.minifyStdJS.os/npm/node_modules/meteor/minifier-js/node_modules/uglify-js/lib/parse.js:1182:35)
at maybe_unary
(/Users/jhm/.meteor/packages/standard-minifier-js/.1.0.6.1ap68qh++os+web.browser+web.cordova/plugin.minifyStdJS.os/npm/node_modules/meteor/minifier-js/node_modules/uglify-js/lib/parse.js:1358:19)

#2

Not even downgrading to 1.3.1 fixed this (last version I successfully deployed with)


#3

check your .meteor/versions file and make sure it’s not still using this version


#4

It is using standard-minifier-js version 1.0.6


#5

Removed it from .meteor/packages and that did the trick