Unwanted padding top in meteor app on pushing routes with react router


#1

I’m creating a basic meteor, which is running into truble.
There’s additional padding at top, and also in between the components.

StackOverflow link to the post containing screenshots of the project

Here’s what i m using in package.json
"meteor-node-stubs": “~0.2.0”,
“react”: “^15.3.1”,
“react-dom”: “^15.3.1”,
“react-router”: “^2.6.1”


#2

This should fix the padding on top of the page:

body, html {
	padding: 0;
	margin: 0;
}

You need to look at your page with developer tools enabled (which you can usually call through pressing F12 in any browser). The developer tools usually have a DOM explorer which you can use to see which styling comes from where.

If you’re seeing a style applied which doesn’t have a source in one of your provided CSS files, then you’re dealing with a browser supplied default style. Which you need to override in order to get what you want.