Update v2.5.6 > v2.5.7 breaks mongo

I can confirm that this worked well for us :+1:

2 Likes

Thank you for the feedback! We’ll release the final version asap.

3 Likes

Hey folks. The 2.5.8-beta.0 works nicely locally but we can’t deploy it with our CI . We’ve switched back to 2.5.7-beta.0 for now

image

HI @marklynch ! It works just fine for us!

Here is the top part of our github-ci.yml file:

name: Orderlion CI

on:
  push:
    branches: [master, development]
  pull_request:
    branches: [development]

jobs:
  test:
    timeout-minutes: 30
    runs-on: ubuntu-latest

    strategy:
      matrix:
        meteor-version: [2.5.8-beta.0]
    
    # Service containers to run with `container-job`
    services:
      # Label used to access the service container
      redis:
        # Docker Hub image
        image: redis
        ports:
          - 6379:6379

    steps:
    - uses: actions/checkout@v2

    - name: Setup timezone
      uses: zcong1993/setup-timezone@master
      with:
        timezone: Europe/Berlin
  
    - name: Install Node
      uses: actions/setup-node@v1
      with:
        node-version: '14.x'

    - name: Use Meteor ${{ matrix.meteor-version }}
      uses: meteorengineer/setup-meteor@v1
      with:
        meteor-release: ${{ matrix.meteor }}

No problems for us here.

Looks good for us too, we are using it in production since yesterday!

That’s odd. We can’t even run the install locally :person_shrugging:

We had the same problem with the 2.5.7 beta. For some reason they don’t upload the install script for beta releases by default, so if you install 2.5.8-beta you get a 403. Instead install 2.5.7 but have your meteor version set to 2.5.8-beta.0 and it will ruj correctly

I have no idea why they do this it’s ridiculous.

Hey @marklynch, this was expected because we usually don’t create tarballs to beta versions to avoid people downloading broken versions.

But I released the version 2.5.8 as an official now, so you can give it a go.

You should be able to run curl https://install.meteor.com\?release\=2.5.8 | sh without any problems.

Also, if you’re running a meteor update or meteor create command, you should also provide the flag --release 2.5.8 to ensure a Meteor automatic update to the latest version won’t happen.

This automatic update happens because we had to create a new dev bundle, to update the node and npm versions. Because of that, the versions catalog on this dev bundle has all the latest versions. So Meteor will check and try to download the latest one.

We’re already studying this behavior and how to fix it.

Why does it install Meteor version 2.7.3 as well when I update to 2.5.8?

Screenshot 2022-06-27 at 13.06.22

Thanks @denyhs, but that makes it difficult or impossible to test these betas on most peoples staging environments I would guess?
The 2.5.7.beta.0 had one. Shouldn’t we make that be an automatic step? I don’t really understand the logic of allowing meteor update of a broken beta but not allowing us to download the same broken beta?

2 Likes

Hi, which version are you trying to update from?

I just did a test updating from 2.5.6, and it worked fine…

Screenshot from 2022-06-27 09-45-58

That’s a good point, yes.

We have an internal process to publish a release, and this step of creating tarballs was always for official releases. But I’ll add this step to betas and RCs as well, no problem.

Were you able to test the official? If you still want to download the beta version, I can create the tarballs for it.

Let me know.

I did update from 2.5.6, that’s when it showed.

However on my two other Meteor projects it didn’t show (and was much faster), both where also from 2.5.6 - however it only happened on the first project I’ve update.

All updates were done within 1h. So far no problems though.

Yeah, 2.5.8 is deployed and working fine thanks! :+1: