Updated MongoDB not matching up with app DB

I updated my MongoDB to the new engine (Wired Tiger) and made no other changes.

Now when I run my app and run ‘meteor mongo’ in a separate terminal, there is no value in a collection (db.collection.findOne() returns null) that does show a value when I log it to the console from a subscribed template.

I think my app may be using 2 databases? How can I check that my app is only using 1 mongodb?

Thanks

when you run meteor mongo command, you will see something like:

MongoDB shell version v3.4.10
connecting to: mongodb://127.0.0.1:3201/meteor

it has host, port, database.

My app is running at http://localhost:3000 and mongodb looks like this when I run meteor mongo:

MongoDB shell version v3.4.10
connecting to: mongodb://127.0.0.1:3001/meteor

I believe this is how it has always looked but the data in the collections does not match up between terminal console and browser?

The only change I made to my project was updating from mmapv1 to Wired Tiger

Meteor app had been running smooth on MacOS High Sierra 10.13 however as I have updated to 10.13.3 today the app won’t respond to when opened. It will simply keep loading (icon jumping on the dock) any idea how to fix it?

Update: I had to uninstall the Meteor app and reinstalled the latest version and it’s working just fine once again! :slight_smile:

Vikas Kundu
showbox.onl/ dltutuapp.com/

Facing the same issue :confused: Uninstalling thr app and reinstalling it again is also not working. Any other solution? Thanks in advance! :slight_smile: 9Apps Cartoon HD