Updating from Meteor 1.5.1 to 1.5.4.1 Broke app

I updated my meteor project and got the following error (truncated the long path to make it easier to read):

W20180326-11:48:32.732(-4)? (STDERR) /[path_to_app]/.meteor/local/build/programs/server/boot.js:475
W20180326-11:48:32.780(-4)? (STDERR) }).run();
W20180326-11:48:32.781(-4)? (STDERR)    ^
W20180326-11:48:32.781(-4)? (STDERR) 
W20180326-11:48:32.781(-4)? (STDERR) ReferenceError: Package is not defined
W20180326-11:48:32.782(-4)? (STDERR)     at packages/underscore.js:1365:1
W20180326-11:48:32.782(-4)? (STDERR)     at packages/underscore.js:1369:3
W20180326-11:48:32.782(-4)? (STDERR)     at /[path_to_app]/.meteor/local/build/programs/server/boot.js:411:36
W20180326-11:48:32.783(-4)? (STDERR)     at Array.forEach (<anonymous>)
W20180326-11:48:32.783(-4)? (STDERR)     at /[path_to_app]/.meteor/local/build/programs/server/boot.js:220:19
W20180326-11:48:32.783(-4)? (STDERR)     at /[path_to_app]/.meteor/local/build/programs/server/boot.js:471:5
W20180326-11:48:32.784(-4)? (STDERR)     at Function.run (/[path_to_app]/.meteor/local/build/programs/server/profile.js:510:12)
W20180326-11:48:32.784(-4)? (STDERR)     at /[path_to_app]/.meteor/local/build/programs/server/boot.js:470:1

I tried uninstalling and reinstalling underscore.js, but that did nothing. I’ve never had a problem with it before.

I also updated the app to meteor 1.6.1 and still got the same error.

Anyone have any ideas why this might be happening?

Thanks!

1 Like

Have you tried a meteor reset and fresh npm install?

This looks like a broken build to me, so a reset should (hopefully) fix it

+1
same problem:

Updating from Meteor 1.3 to 1.6.1

W20180327-14:02:18.702(3)? (STDERR) /home/lesp1ker/support/support_1.6/.meteor/local/build/programs/server/boot.js:475
W20180327-14:02:18.703(3)? (STDERR) }).run();
W20180327-14:02:18.704(3)? (STDERR) ^
W20180327-14:02:18.704(3)? (STDERR)
W20180327-14:02:18.704(3)? (STDERR) ReferenceError: Package is not defined
W20180327-14:02:18.704(3)? (STDERR) at packages/underscore.js:1365:1
W20180327-14:02:18.705(3)? (STDERR) at packages/underscore.js:1369:3
W20180327-14:02:18.705(3)? (STDERR) at /home/lesp1ker/support/support_1.6/.meteor/local/build/programs/server/boot.js:411:36
W20180327-14:02:18.705(3)? (STDERR) at Array.forEach ()
W20180327-14:02:18.706(3)? (STDERR) at /home/lesp1ker/support/support_1.6/.meteor/local/build/programs/server/boot.js:220:19
W20180327-14:02:18.706(3)? (STDERR) at /home/lesp1ker/support/support_1.6/.meteor/local/build/programs/server/boot.js:471:5
W20180327-14:02:18.706(3)? (STDERR) at Function.run (/home/lesp1ker/support/support_1.6/.meteor/local/build/programs/server/profile.js:510:12)
W20180327-14:02:18.707(3)? (STDERR) at /home/lesp1ker/support/support_1.6/.meteor/local/build/programs/server/boot.js:470:11

“meteor reset and fresh npm install” did not help

I did a fresh install of meteor and ported my code to it. I added my meteor packages back in one at a time, and that seemed to fix it. There must be a better way, but so far that seems to be the only thing that worked for me.

I got the same issue. So I decided to update just to Meteor 1.4

Has anyone fixed this issue without having to port code to a fresh install? I’m having the same problem starting at 1.4, and can’t upgrade meteor at all because of it

1 Like