Updating package catalog - packages.meteor.com down


#1

I have been unable to add anything to my project for 20 minutes now. packages.meteor.com returns a blank page.

Tried from EC2, Digital Ocean, and my local computer with same results so it’s not just me.

Any news about what’s happening and how long this will last?

Also, it would be very helpful to add the packages site added to status.meteor.com

Thanks,
YF


Stuck at Updating Package Catalog
#2

For anyone else stuck adding packages while this is going on, you can use your offline catalog like I just did:

METEOR_LOG=debug METEOR_OFFLINE_CATALOG=1 meteor add ...


#3

Everything is back to normal now:


#4

Nice, this solve my problem


#5

Yes, @hwillson.
Now the “Updating package catalog” runs normally. Maybe a instability from the meteor host install service?


#6

running into this issue right now (Jul 18/2016). packages.meteor.com returning blank page.

Running with METEOR_OFFLINE_CATALOG works.


#7

+1 here! Running with METEOR_OFFLINE_CATALOG works.


#8

It works now. Looks like their site was down.


#9

Appears the package server is down again??

“As of a few minutes ago, I believe the package server is back in business, after I stopped and restarted all of its containers.”


#10

Yup, it seems to be down for me as well, I’m stuck at “Updating package catalog” :confused:

Edit: Running with METEOR_OFFLINE_CATALOG=1 solved the problem :slight_smile:


#11

Unfortunately, this doesn’t work for me :disappointed:


#12

Same…“Updating package catalog” constantly


#13

Thanks for this, looks like meteor package repo was down


#14

@yfilali
How did you get the METEOR_OFFLINE_CATALOG=1 to work in command line?


#15

If you wait long enough and have downloaded the package in the past, you might see the following after about 5 minutes.


#16

@corphiloscience: using bash or zsh, type it before the meteor command like this “METEOR_OFFLINE_CATELOG=1 meteor add package-name”. if you want it to stick so you don’t have to type it over and over, add it to your .bashrc as “export METEOR_OFFLINE_CATALOG=1”. You’ll have to manually update your catalog occasionally if you do that though.

If you’re on windows, you may have to do SET METEOR_OFFLINE_CATALOG=1 or something like that…


#17

Working for me now. I clearly don’t have the patience to wait 5 minutes. As typically happens with technology, if I had been patient enough and waited to post would the system have fixed itself and would I still be hovering over the reply button now? Since I did decide to post is that what caused Hal to kick into gear and fix the problem? We shall never know the true answer…get back to work