Upgrade from 1.4.2 to 1.4.2.3 has broken my bootstrap readonly


#1

I have a couple of readonly text boxes on my template and since upgrading from 1.4.2 to 1.4.2.3 these are no longer readonly. I am using twbs:bootstrap but this wasn’t upgraded at the same time (this is still version 3.3.6).

My text box HTML is standard…

<input type=“text” readonly class=“form-control” name=“meets_current_design_spec” id=“meets_current_design_spec” value="{{meets_current_design_spec}}" placeholder=“Meets Current Design Spec.”>

However when I inspect the element in Chrome…

The readonly has been completely removed.

I can manually add this back in through Chrome and the text box goes readonly but it isn’t readonly when generated from Meteor?

Any help would be much appreciated!

Here is full the update output of my update command…

$ meteor update --all-packages

Changes to your project’s package version selections from updating the release:

accounts-password upgraded from 1.3.1 to 1.3.3
babel-runtime* upgraded from 0.1.13 to 1.0.1
caching-compiler upgraded from 1.1.8 to 1.1.9
coffeescript upgraded from 1.2.6 to 1.11.1_3
ecmascript upgraded from 0.5.9 to 0.6.1

  • These packages have been updated to new versions that are not backwards
    compatible.
    workspace: updated to Meteor 1.4.2.3.

Changes to your project’s package version selections from updating package versions:

blaze upgraded from 2.1.9 to 2.2.0
coffeescript upgraded from 1.11.1_3 to 1.11.1_4
ddp-common upgraded from 1.2.7 to 1.2.8
ddp-server upgraded from 1.3.11 to 1.3.12
launch-screen upgraded from 1.0.12 to 1.1.0
minimongo upgraded from 1.0.18 to 1.0.19
momentjs:moment upgraded from 2.15.2 to 2.17.0
stylus upgraded from 2.513.6 to 2.513.8


AutoForm "readonly=true" don't work when update blaze to 2.2.0?
#2

has the readonly been removed in any other browsers?


#3

I have tested in IE11 as well and it is the same.


#4

Is

<input type="text" readonly class="form-control" name="meets_current_design_spec" id="meets_current_design_spec" value="{{meets_current_design_spec}}" placeholder="Meets Current Design Spec.">

Exactly as it appears in the template? In other words is readonly definitely a literal and not a helper?


#5

Yes. I have tried readonly=“true” as well but that is the same.

It was working fine before the upgrade and nothing has changed since to the code.


#6

Technically, that’s invalid syntax. You could try readonly="readonly", but I don’t see why that would be any better than readonly.


#7

Ok thanks. I tried readonly=“readonly” and that doesn’t make a difference either.


#8

Can you put together a minimal reproduction and submit an issue?


#9

I had the same problem. You have to use readOnly and a true value. Don’t know why, but this solved the problem for me.


#10

Hi, I tried readOnly=“true” but that made no difference to me. The text box still isn’t read only. Can you provide a full example of the text box HTML you used that worked? Thanks, Matt.