Upgrade MongoDB driver on Meteor 1.7.0.4


#1

I need to use MongoDB driver version 3.1.4 as there are some retryable writes fixes there for bulk updates (https://jira.mongodb.org/browse/NODE-1513)

How can I upgrade the driver version from 3.0.11 to 3.1.x?


#2

You’ll need to clone the npm-mongo package into your packages/ folder and edit the package.js file accordingly.


Multiple unwanted mongodb connections saturates db deployment
#3

Isn’t this coming in Meteor 1.7.1?


#4

It may, but the current next release documentation still states 3.0.11.


#5

The driver has already been updated on the release-1.7.1 branch: https://github.com/meteor/meteor/blob/release-1.7.1/History.md. :slightly_smiling_face:


#6

Do we have a release date for 1.7.1?


#7

It will be released when it is ready. It is currently in RC stage so I don’t think it will be too long.


#8

You can of course use 1.7.1-rc.5 if you cannot wait…