Upgrade to 1.4.1.1 Error


#1

I recently upgraded to 1.4.1.1 from 1.3.5.1 and keep getting the following error out of the blue:

Exception in setInterval callback: MongoError: Cannot apply $pull to a non-array value                                                                                                                                                                                                                                                                        
I20160902-15:08:19.814(-5)?     at Object.Future.wait (/Users/aadams/.meteor/packages/meteor-tool/.1.4.1_1.8t0inl++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/server-lib/node_modules/fibers/future.js:449:15)                                                                                                                                                     
I20160902-15:08:19.814(-5)?     at MongoConnection.<anonymous> (packages/meteor/helpers.js:119:1)                                                                                                                                                                                                                                                                                         
I20160902-15:08:19.814(-5)?     at MongoConnection.(anonymous function) [as update] (packages/mongo/mongo_driver.js:771:49)                                                                                                                                                                                                                                                               
I20160902-15:08:19.815(-5)?     at [object Object].update (packages/mongo/collection.js:589:29)                                                                                                                                                                                                                                                                                           
I20160902-15:08:19.815(-5)?     at [object Object].Mongo.Collection.(anonymous function) [as update] (packages/aldeed_collection2/packages/aldeed_collection2.js:167:1)                                                                                                                                                                                                                   
I20160902-15:08:19.815(-5)?     at AccountsServer.Ap._expirePasswordResetTokens (packages/accounts-base/accounts_server.js:1137:14)                                                                                                                                                                                                                                                       
I20160902-15:08:19.815(-5)?     at packages/accounts-base/accounts_server.js:1174:14                                                                                                                                                                                                                                                                                                      
I20160902-15:08:19.816(-5)?     at [object Object]._.extend.withValue (packages/meteor/dynamics_nodejs.js:56:1)                                                                                                                                                                                                                                                                           
I20160902-15:08:19.817(-5)?     at packages/meteor/timers.js:6:1                                                                                                                                                                                                                                                                                                                          
I20160902-15:08:19.817(-5)?     at runWithEnvironment (packages/meteor/dynamics_nodejs.js:110:1)                                                                                                                                                                                                                                                                                          
I20160902-15:08:19.817(-5)?     - - - - -                                                                                                                                                                                                                                                                                                                                                 
I20160902-15:08:19.818(-5)?     at Function.MongoError.create (/Users/aadams/.meteor/packages/npm-mongo/.1.5.48.698dqt++os+web.browser+web.cordova/npm/node_modules/mongodb-core/lib/error.js:31:11)                                                                                                                                                                                      
I20160902-15:08:19.818(-5)?     at toError (/Users/aadams/.meteor/packages/npm-mongo/.1.5.48.698dqt++os+web.browser+web.cordova/npm/node_modules/mongodb/lib/utils.js:114:22)                                                                                                                                                                                                             
I20160902-15:08:19.818(-5)?     at /Users/aadams/.meteor/packages/npm-mongo/.1.5.48.698dqt++os+web.browser+web.cordova/npm/node_modules/mongodb/lib/collection.js:1042:67                                                                                                                                                                                                                 
I20160902-15:08:19.818(-5)?     at /Users/aadams/.meteor/packages/npm-mongo/.1.5.48.698dqt++os+web.browser+web.cordova/npm/node_modules/mongodb-core/lib/connection/pool.js:430:18                                                                                                                                                                                                        
I20160902-15:08:19.819(-5)?     at nextTickCallbackWith0Args (node.js:420:9)                                                                                                                                                                                                                                                                                                              
I20160902-15:08:19.819(-5)?     at process._tickDomainCallback (node.js:390:13)    

For the most part I followed this guide. I’m on my local box and have a MONGO_URL path pointed at mLabs (which is on mongod version: 3.0.12 (MMAPv1)).

Someone please help so I can finish my upgrade to 1.4.


#2

Looks like a bug, fixed here: https://github.com/meteor/meteor/pull/7643

Perhaps something that should be released soon.


#3

@sashko I’ll roll back and wait for the fix then. It’s just, for whatever reason, I can’t get React to work for me unless I’m on 1.4.1.