Upgrade to Meteor 2.13 leads to failure on node modules installation

@grubba, Which distribution do you use in the two systems?

1 Like

Same here, see also Meteor build fails with exit status 1 due to version `GLIBC_2.33' not found

Maybe that’s the problem, I’m using AWS for starters, not sure where @pbeato is trying to deploy.

Seems some OS like ubuntu 20.04 uses an older version of glibc than what is used to compile the meteor build

Any idea how this can be solved, RJ?

The team just launched a new version to fix this issue. Can you try again using the 2.13.3 version?

I will try to rebuild it again but like I wrote I didn’t install 2.13.1 either so I still don’t understand why it selected that specific version for the Meteor tool.

The fix worked @hschmaiske - thanks to the team for such a quick solution

1 Like

Glad it worked @a4xrbj1!

@a4xbj1, we use a docker based on version 14-bulleye-slim for distribution. @grubba, could you please tell us which distribution you use on which platforms it works?

Can you explain what happened and what was done to fix it? “Here’s a fix” is not very instructive to understanding the root cause and the change needed to make it work. Clear summarizations make these threads far more useful for future readers, increases trust, and reduces frustration from both users and those called upon to help.


@grubba: with version 2.13.3, which is neither documented nor officially released, it seems to work correctly. Where should we look to be updated on these important changes? We are talking about sites in production with an uncertified version of node. Thank you.

1 Like

Hey, there is a changelog for 2.13.3



For those of us not working on the codebase, it isn’t so clear what changes were made to fix the release. Based upon reading the changelog, I understand

  1. The ESM Node.js release (v was compiled on a CentOS Linux distro.
  2. The release (v that was creating the error posted above was because it was compiled on a Ubuntu Linux distro.

Do I have that right?

Yeah, Alim! You got it. I’ve made this fix while travelling. That is the reason why it is missing some pieces. I’m planning on starting working today on adjusting these edges.


Just a heads up @grubba that CentOS 7 will EOL next year. I supposed this is what you are using to get a low version glibc that is still maintained.

Rocky linux looks like a viable option for long term support short of going straight to RHEL. Rocky linux 8 will bump glibc to 2.28.

Ubuntu 20.04 is at 2.31.


Thanks! @rjdavid will let the DevOps team know.

Thanks for this fix.

I am trying to run the Meteor 3 version (METEOR@3.0-alpha.11) to start testing and being familiar with the next version, and I am running with the same issue mentioned here on my system (using still an older version of Ubuntu 20.04).

Error: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.33’ not found

Will you include the fix from 2.13.3 about the glibc in the next Meteor 3 alpha version?

PD: Not blocking my testing actually since I provisioned a WSL Ubuntu 22.04 for the testing.


@grubba …also fourseven:scss has a problem after upgrading to 2.13.

Hey, what is the error you are receiving? Maybe is related to this issue[solved]?