Upgrade to Meteor 2.13 leads to failure on node modules installation

As of today, running the meteor npm install command in Meteor version 2.13 I get an incorrect data check error. I have tried deleting the lock file and the npm cache without success. Does the same thing happen to any of you?

Running the same sequence from meteor version 2.7.3 it works fine.

We have the same problem here :frowning, with, apparently, the same npm version.

➜  master git:(4914-feat) meteor --version     
Meteor 2.7.3                                  
➜  master git:(4914-feat) meteor node --version
➜  master git:(4914-feat) meteor npm --version   
➜  master git:(4819-feat) meteor --version     
Meteor 2.13
➜  master git:(4819-feat) meteor npm --version
1 Like

Same problem. Please verify node update. Npm log is

5806 verbose stack ZlibError: zlib: incorrect data check


With version 2.12 it does not occur

I tried a different version of npm with the version of node provided by meteor 2.13 with no luck. Changing node from 14.21.4 to 14.21.3 instead it works. It seems that the problem was introduced after this change Patch security changes by denihs · Pull Request #1 · meteor/node-v14-esm · GitHub

1 Like

@grubba @denyhs tagging you here since you were indicated in the PR

I had the same error messages as well when trying to update the packages. Thanks for digging into it, my AWS Fargate deployments failed due to this Meteor update see Upgrade to Meteor version 2.13 leads to all my AWS deployments failing - #8 by rjdavid

The team is studying how to tackle this issue.
I could not reproduce it within my machine(also why I thought all was ok), and all tests from all CIs were green.
Yesterday I tried with my old Mac Air(2017/intel), and I got the error, so at least I have someplace I can test the changes and see if they will work.

Docker image with node 14.21.4
If you have any command that uses the system node, you might want to prefix it with meteor for example:

node somescript.js

should be:

meteor node somescript.js

this ensures that you are using Meteor’s node version.

1 Like




I have the same problem.

Does anyone understand why we have this error ?
I did a meteor reset then a meteor update and i receive this error :

dokithonon@thomass-macbook-pro rationalk % meteor update    
This project is already at Meteor 2.13, the latest release.
      throw error;

Error: incorrect data check
    at Zlib.zlibOnError [as onerror] (zlib.js:187:17)
 => awaited here:
    at Promise.await (/Users/dokithonon/.meteor/packages/meteor-tool/.2.13.0.ppw8xj.087j++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/lib/node_modules/meteor-promise/promise_server.js:60:12)
    at Object.extractTarGz (/Users/dokithonon/.meteor/packages/meteor-tool/.2.13.0.ppw8xj.087j++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/tools/fs/tools/fs/files.ts:791:11)
    at Object.exports._extractAndConvert (/tools/packaging/tropohouse.js:47:9)
    at /tools/packaging/tropohouse.js:502:42
    at Object.enterJob (/tools/utils/buildmessage.js:388:12)
    at /tools/packaging/tropohouse.js:499:24
    at Function.each (/Users/dokithonon/.meteor/packages/meteor-tool/.2.13.0.ppw8xj.087j++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/lib/node_modules/underscore/underscore-node-f-pre.js:1316:7)
    at /tools/packaging/tropohouse.js:466:11
    at Object.enterJob (/tools/utils/buildmessage.js:388:12)
    at Object.download (/tools/packaging/tropohouse.js:424:20)
    at /tools/packaging/tropohouse.js:597:22
    at Object.enterJob (/tools/utils/buildmessage.js:388:12)
    at exports.Tropohouse.downloadPackagesMissingFromMap (/tools/packaging/tropohouse.js:594:20)
    at /tools/project-context.js:921:25
    at Object.enterJob (/tools/utils/buildmessage.js:388:12)
    at /tools/project-context.js:920:20
    at /tools/packaging/catalog/catalog.js:100:5
    at Object.capture (/tools/utils/buildmessage.js:283:5)
    at Object.catalog.runAndRetryWithRefreshIfHelpful (/tools/packaging/catalog/catalog.js:99:31)
    at ProjectContext._downloadMissingPackages (/tools/project-context.js:919:13)
    at /tools/project-context.js:365:35
    at Object.enterJob (/tools/utils/buildmessage.js:388:12)
    at ProjectContext._completeStagesThrough (/tools/project-context.js:355:18)
    at /tools/project-context.js:347:12
    at Function.run (/Users/dokithonon/.meteor/packages/meteor-tool/.2.13.0.ppw8xj.087j++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/tools/tool-env/tools/tool-env/profile.ts:289:14)
    at ProjectContext.prepareProjectForBuild (/tools/project-context.js:346:13)
    at /tools/cli/commands-packages.js:1929:22
    at Object.capture (/tools/utils/buildmessage.js:283:5)
    at Object.main.captureAndExit (/tools/cli/main.js:279:29)
    at Command.func (/tools/cli/commands-packages.js:1908:8)
    at /tools/cli/main.js:1534:15 {
  errno: -3,

It looks like this is linked to pdfmake (this occurs when I use pdfmake to render pdf on the page)
Images on pdf are not rendered with 2.13 but rendered with Meteor 2.12
As soon as I go back to Meteor 2.12 the error disapears

May be related.
I am on macbook air M1. Upgraded from 2.12 to 2.13. I use pdfmake 0.2.7 (version without promises) server side only with 2.13 and it works.
I reinstalled all npm packages after upgrade and downgraded fibers to 5.0.2 to force build because pre-build 5.0.3 throws incorrect data check at Zlib.

I am getting the same kind of error message when I add the blaze-html-templates package to my projects, not sure what is going on.

Are there any updates around this issue? Maybe I’m wrong but I see no activity related to this topic; this problem is blocking our passage to Meteor 2.13.

1 Like

@mlubian you can watch this : Migrating to Meteor 2.13 | Meteor Guide, and this Cannot extract any version of meteor tool · Issue #12731 · meteor/meteor · GitHub :face_with_monocle:
Upgrading from 2.8, I’m staying safely at 2.12 until this issue is solved …


@lc3t35 The urgency to upgrade to 2.13 is to install the node security updates applied to the bundle version. Staying with 2.12 or earlier means not having the desired security levels.

1 Like

Hi @pbeato, of course safely was related here to the instability of 2.13, not to security issues. I didn’t check why node/meteor was updated for security, do you have a cve link ?
It seems that 14.21.3 has fixed last cve known for 14.21.1 : Nodejs Node.js version 14.21.1 : Security vulnerabilities, CVEs

(edit) Got it here : Patch security changes by denihs · Pull Request #1 · meteor/node-v14-esm · GitHub

Hello @grubba and @denyhs, could you please update on the progress of this issue? As this is the first application of a patch on the independently supported node 14, it would be interesting to see when we would be able to have safe production installations.

1 Like

For those who are with the zlib issue, we have great news!

curl https://install.meteor.com/\?release\=2.13.1 | sh

It will probably solve your issues downloading and unpacking packages.

1 Like

Thanks @grubba, I tried to use the above versione but I got the error:

14:43:33  internal/modules/cjs/loader.js:1175
14:43:33    return process.dlopen(module, path.toNamespacedPath(filename));
14:43:33                   ^
14:43:33  Error: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.33' not found (required by /home/node/.meteor/packages/meteor-tool/.2.13.1.gadqg5.bafha++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/lib/node_modules/vscode-nsfw/build/Release/nsfw.node)
14:43:33      at Object.Module._extensions..node (internal/modules/cjs/loader.js:1175:18)

Normally, we use a 14-bullseye-slim docker image to generate the build, but I also tried the 18-bullseye-slim with the same error.

1 Like

That is really weird! We tested in galaxy both using the CLI and P2D and it did worked without any changes