Upgrading Mongo Driver - Stuck at 2.6.10? [Solved, am muppet]


#1

Hi,

Seeing the below.

image

Unless I’m totally missing something, shouldn’t the Mongo driver for the Meteor 1.8 be 3.6 or something? Why is this stuck at 2.6.10, and how can I upgrade it?

Pointers much appreciated. Thanks so much.


#2

My first thought is that you might have the 32bit version of Meteor, which because Mongo dropped support for 32bit is a few versions behind.
The switch from 32bit to 64bit required a re-install, so if you haven’t done one, that could be why?


#3

hey mate - i’m on ubuntu 16.04.

So on doing curl https://install.meteor.com/ | sh it did a full remove and reinstall. Unfortunately, still on the old version of mongo db driver. No dice.

image

image


#4

I just tried it on my mac, and realised something

All the bundled stuff is launched by meteor, and isn’t on the PATH
So you should check versions like this: (excuse my dirty bash prompt)

2018-11-09 11:55:47 - Freds-MacBook-Pro-2 in ~/projects/dg-cms/src
± |devel U:9 ✗| → meteor --version
Meteor 1.8

2018-11-09 11:57:27 - Freds-MacBook-Pro-2 in ~/projects/dg-cms/src
± |devel U:9 ✗| → meteor node --version
v8.11.4

2018-11-09 11:57:32 - Freds-MacBook-Pro-2 in ~/projects/dg-cms/src
± |devel U:9 ✗| → meteor npm --version
6.4.1

2018-11-09 11:57:40 - Freds-MacBook-Pro-2 in ~/projects/dg-cms/src
± |devel U:9 ✗| → meteor mongo
meteor:PRIMARY> db.version()
4.0.2

Note: I had meteor running in another shell to be able to connect to the mongo db in development

node, npm and mongo, without meteor will use whatever is installed on your system rather than what’s bundled with Meteor.

Sorry for telling you to re-install!


#5

You’re a genius. That makes sense - clearly at some point i had installed mongo, but that is not what meteor is using. rather, it is using its own bundled version. that makes perfect sense.

also:

image

lol… my bad. the question was dodgy.


#6

haha definitely been there before!