Upgrading to 1.6 will prevent app from running


#1

I upgraded my meteor app to 1.6 and there did not appeared to be any problems with the upgrade. When I ran the application it took a long time for the “App Running at: http://localshost:3000” to appear.

Then when I opened the browser and tried running the app I get the following error:

EXCEPTION: Maximum call stack size exceeded

I believe this is due to the fact for some reason I’m unable to read the HTML templates. Currently most of my components are reading in the html as follows:

import template from './partyOne-container.component.html';

@Component ({
	selector: 'crm-customers-partyone-container',
	template
})

I take the root component and change it to the following it works:

@Component({
	selector: 'app',
	moduleId: module.id,
	templateUrl: 'app/app.component.html',
	template: '<h2>We are here<h2>',
...

The app loads just fine and there are no errors. So before I was using meteor 1.5.2 this syntax worked. But for some reason now it does not work. I’ve even tried using the templateUrl with absolute paths and it does not work either:

Here is the app.component.html file

<h1>Do you feel you are being heard.</h1>

Here is the app.component.ts file

@Component({
	selector: 'app',
	moduleId: module.id,
	templateUrl: 'app/app.component.html',
	providers: [
		RootModalService,

I’ve tried various different absolute paths but none of them seem to work. Does anyone have any idea what would be causing this.

UPDATE

I just noticed that the source maps are not being generated. And when I look at the compiled JavaScript for the line

//** Templates */
import template from './app.component.html';

it gets transpiled as

//** Templates */
const app_component_html_1 = require("./app.component.html");

When I put a break point on that line and inspect the value of app_component_html_1 I get the following:

> app_component_html_1
{default: "client/imports/app/app.component.html"}

Should this be showing the actual contents of the HTML file?


#2

Hey, wish I could help but I don’t know anything about the angular compiler and why it might be failing here.

This is more than serious enough to warrant an issue report here:

Which angular compiler are you using?


#3

Below is list of the libraries:

"angular2-meteor": "0.7.1",
"angular2-meteor-polyfills": "0.2.0",
"angular2-meteor-tests-polyfills": "0.0.2",
"angular2-modal": "^2.0.2",
"angular2-moment": "^1.5.0",
"angular2-text-mask": "4.1.0",
"babel-plugin-transform-html-import-to-string": "0.0.1",
"babel-runtime": "^6.18.0",

#4

I think I saw that angular2-compilers was deprecated in favour of angular-compilers

Might be worth a try to swap those and see if that helps at all


#5

Android SDK 27 & java 9x are still not compatible…I downgraded and the app worked for me.


#6

Would this be the reason why my source map files are not produced?