URGENT: Can't deploy my app to Galaxy

I’m trying to deploy my app to Galaxy and I’m getting errors before the upload to galaxy begins. Below is my configuration:

  • Mac OS
  • Meteor 1.8.1. (Was unable to upgrade to 1.10 or 1.9)
  • Running in Angular and Typescript

Here is the error:
Errors prevented deploying:

While processing files with angular-compilers (for target web.browser):

packages/angular-typescript-compiler/index.js:337:51: Cannot read property 'loadResource' of undefined
at Promise.asyncApply (packages/angular-typescript-compiler/index.js:337:51)
at /Users/andressosa/.meteor/packages/meteor-tool/.1.8.0_1.164g4nt.f5hr++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/lib/node_modules/meteor-promise/fiber_pool.js:43:u5408:

Updating to Meteor 10

OK. I think I’m getting somewhere with this. I think the problem is related to the issues I’ve been having with migrating to Meteor 10.
It appears that the issue is that when Meteor is doing the upgrade it is using node-sass@4.7.2. This appears to be a problem when it is not compatible with the version of node that I’m on.

Question #1

How do I upgrade the node-sass@4.7.2 to the latest in Meteor?

Well I ran the following scripts and that did not help:

 % npm install -global node-sass 


 % meteor npm install -global node-sass

But when I run the

 % meteor update --patch

I still get the following error

gyp ERR! cwd
gyp ERR! node -v v12.16.1
gyp ERR! node-gyp -v v3.6.2
gyp ERR! not ok 
Build failed with error code: 1
npm ERR! errno 1
npm ERR! node-sass@4.7.2 postinstall: `node scripts/build.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the node-sass@4.7.2 postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:

As you can see it is still using the node-sass@4.7.2 which is not compatible with node version v12.16.1.
So this Question #1 stands.