[Urgent]Somehow meteor stuck at downloading meteor-tool 1.1.9


#1

I am trying to install meteor on a ubuntu server (actually I first tried a few docker containers including debian and ubuntu) as a build machine for my meteor app mainly using meteor 1.2.0.4 with react, flow-router etc.
For example, I start a fresh ubuntu docker container and install meteor directly. Then I clone the meteor project and run meteor directly, after it successfully downloaded meteor-tool@1.1.9, it seems stuck there, always showing " Downloading meteor-tool@1.1.9… -".

I was able to build this project on my mac though. Any help is appreciated.
Thanks,


Downloading meteor-tool@1.1.9
#2

I just had the same issue with meteor-tool@1.1.10 :frowning:

Anyone knows how to solve this?


#3

Hello, xigua. I had the same problem as you. Did you try to download the tool 1.1.9? Perhaps it is because you started in version 1.2.0.4 therefore possessed no dependencies of version 1.1.x of the framework, or at least that’s what happened to me. You can try the “meteor update” command before using “meteor run”. I hope it helps you. Greetings!


#4

Hello, I had the same issue, & when I stopped with a “CTRL+C” a message told me there was a matter with a folder in C:\Users<my_user_name>\AppData\Local\Temp. (AppData is not visible , you have to type it in the adress bar )
I deleted all folders in this temp folder , and when i launched “meteor” it creates 2 folder with random name. The one which start with a “.tmp” owns a ‘meteor-tool-1.1.9’ folder that grows and in this we can see some package are dowloading —> I’m wainting --> more than 161 Mo
Then this packages are transfered to the second folder, and the ‘.tmp’ folder disapear…

still waiting |-{ but nothing

this happens when following a tutorial :
I followed, but something was wrong, so I decided to grab this https://github.com/DiscoverMeteor/Microscope/tree/2df3a7ab125ce901495c70003170aa51ef56aa9d

, started a new app, and replaced all files of mine with those, create a new app, no “Router” were found --> it didn’t find iron-router… so I copied the .meteor/package file downloaded to my new one and when I run Meteor , it updated all package --> this works !


#6

Hi I’m experiencing the same with you using the lates meteor-tool 1.3.3 I also experience stuck download when using meteor add iron:router. Need help on this one. By the way I also tried meteor update an it takes so long also to download. Need insights on this matter. See my screen capture below. Thank you


#7

I’m having exactly the same problem when doing “meteor update”. I’m trying that because “meteor run” takes forever.

Need advice!


#8

I have the same problem, too. It gets stuck when downloading the meteor-tool 1.3.3_1. Any solution yet?


#9

This issue is (likely) CDN related and is being tracked here:


#10

Same problem :frowning: Any solutions yet?


#11

Were you able to solve this issue? I am stuck at same :frowning: . Please give me the direction if any.
Thanks


#12

Same issue man. I haven’t found anything.


#13

Try this

curl https://install.meteor.com | sh```

#14

I was able to get it to work by deleting all of the .tmpXXXX folders from
the Temp folder, then deleting the .meteor folder as well, uninstalling
meteor and then installing a freshly downloaded installer

not pretty, but that made it work…

for the deletion of those folders I actually had to create a little
recursive script to first rename the subfolders so that windows would
delete them…


#15

For how long do you guys wait? I’ve had downloads of meteor-tool that took over half an hour (I think it’s because it needs to do other stuff like ES6 compilation and installing dependencies on your machine).


#16

I’m stuck on this now, and it’s a pitfa.

First my meteor install was screwed up by what seemed a failed install of 1.3.3_1 which had modified the metoer batch file but was not working.

Now I reverted back to 1.3.3 and it hangs on Downloading meteor-tool@1.1.10 for ages then crashes on an error.


#17

Hey guys

I had the same problem using meteor 1.3 and solved running meteor --release 1.2.1 in the project folder


#18

Try adding 54.192.225.217 warehouse.meteor.com to your hosts file. Worked for me.


#19

I solved this problem by uninstalling meteor and after successfully uninstalled. I installed the newly fresh downloaded meteor and it works perfectly now.


#20

Hi, I had the same issue. MY SOLUTION: I was erroneously running meteor outside of my project folder. When I move to the proper meteor project folder the tool downloading issue disappear. =P


#21

I have this problem many times on bad wifi connection. Looks like it don’t can reconect again…