I am running Meteor 22.214.171.124 which uses React 16.0,0
I make use of react-komposer in my “data fetching” components. So this results in the warning:
npm WARN firstname.lastname@example.org requires a peer of react@^0.14.7 || ^15.0.0 but none was installed.
I understand that I can get rid of this warning by simply installing, say, React v 15.0.0 too. But this seems like it could just add to the volume of code costing execution speed? If both React versions ( 15.0.0 and 16.0.0) are installed, could they possibly conflict with each other in any situations?
Should I just ignore this warning - that is, does it really matter?
If this warning is substantial, maybe someone knows if I can simply “point” react-komposer to use React 16.0.0 and thereby get rid of the warning?
Or maybe having both React 15.0.0 and 16.0.0 installed is common practice and does not cause any problems at all?
Alternatively - I am thinking that it would be best to just remove react-komposer and use react-meteor-data instead; that is react-composer will be gone fairly soon, if not already.
Thanks for any insights – jw