V and React-Komposer warning



I am running Meteor which uses React 16.0,0

I make use of react-komposer in my “data fetching” components. So this results in the warning:

npm WARN react-komposer@2.0.0 requires a peer of react@^0.14.7 || ^15.0.0 but none was installed.

I understand that I can get rid of this warning by simply installing, say, React v 15.0.0 too. But this seems like it could just add to the volume of code costing execution speed? If both React versions ( 15.0.0 and 16.0.0) are installed, could they possibly conflict with each other in any situations?

Should I just ignore this warning - that is, does it really matter?

If this warning is substantial, maybe someone knows if I can simply “point” react-komposer to use React 16.0.0 and thereby get rid of the warning?

Or maybe having both React 15.0.0 and 16.0.0 installed is common practice and does not cause any problems at all?

Alternatively - I am thinking that it would be best to just remove react-komposer and use react-meteor-data instead; that is react-composer will be gone fairly soon, if not already.

Thanks for any insights – jw


Well I added React 15.0.0 and kept the original 16.0.0 also. I used a “meteor npm install …” style command to do so.

This lead to other problems.

So I have to conclude that adding 2 different versions of React causes them to interact in some respect.

Don’t have time to dig into the details. So decided to switch over to use react-meteor-data and say good-bye to react-komposer.