Velocity - Serverside tests aren't running, logs reporting sockjs connection errors on Windows


#1

Trying to get Velocity to work properly on Windows and running into weird issues.

If we try to use the VELOCITY_MONGO_URL parameter for a remote DB we get “MongoError: auth failed”

If we use a local DB, Velocity will start but it will report handshake 404 errors and none of our serverside tests will report.

Has anyone run into this before? Did I miss a configuration step?


#2

Bump. Still no solution to this. Same thing happens on Windows and Linux, none of our mocha tests run.


#3

Okay, we’ve finally figured out what was going on.

Auth Error) We traced the mocha connection and found it was trying to create its own DB with “-mocha” appended. Our cloud broker doesn’t allow a DB to be created on the fly, so instead we’ve provisioned a DB with name “appDBname-mocha” and configured Velocity’s connection string for just “appDBname”.

404 handshake errors) Turns out Velocity was respecting our proxy settings and attempting to leave our intranet, which caused this issue. Disabling our proxy settings prior to running the test suite fixes the issue.