Very old web app on Meteor, freezes during upgrade

I am attempting to update dependencies and meteor on this web app but every time I attempt to do ‘meteor update’, meteor starts downloading, extracting, and then freezes my droplet (and AWS Instance). I read something that when upgrading, I would need to update up to 1.8 and then follow a new procedure… But, even if i attempt to update meteor by using a specific version (meteor update --release ) it still freezes.

Though, the web app will work without any issues locally on my mac and pc.

any help would be greatly appreciated

If you are on windows, try using power shell as administrator. That solved my update issues.

Hey Baris, thanks for your reply! It happens on a Linux server. But what’s funny is that on my local Linux machine (or windows using CMD or Powershell, or using Mac) it goes through without freezing. I thought it was a memory/recourses issue, but that was not the reason. Issue still unresolved

The easiest would be to upgrade and build your app locally and then update it to the server. Did it freeze even when you attempted to update to the next patch version?
Just to confirm, it is freezing on extracting of the update, not on getting it?

1 Like

That’s correct. It freezes during initial downloading or extracting of meteor_tool. Sometimes it’s one or the other. And it doesn’t matter if I tried,, or even if I jumped to The issues were identical. Only one that worked was the latest meteor build 2.9.1 I believe but that jump breaks the app. The app is currently not running because of this issue so idk how I’d be able to build locally and deploy it to droplet. The project is quite old (last code or package updates were done in 2016). If I update meteor on my local machine, meteor will update but the app breaks.

I’m honestly not sure why, with no changes, this was able to work a couple of years ago and now during download or extracting meteor_tool, things just freeze up on the droplet

I don’t know how to deploy on AWS but I think your best bet is to update and build locally. I assume you already know you can update meteor project to s specific release.

Another option you can try is to find which package is failing to extract and remove files before trying to update again.

Yes I’m aware of how to update to a specific release. Just have to sort out the breaking changes between and current release… and that will take some time

I thought you wanted to update to 1.8

I would prefer 1.8 over 1.4. But when I did update to 1.8, the app broke.

Forgive me as I’m still fairly new to Meteor, let alone JavaScript. I have a general understanding what “things” do but when it comes to debugging breaking changes, I just go blank.

Changelog | Meteor API Docs

In a similar case I had to go trough every “Breaking Changes”, I don’t know any easier way.

With my lack of experience, I honestly don’t even know how to find, let alone fix, these breaking changes. I did read the changelog of, for example, going from to 1.6, but honestly don’t know where in my project needs these fixes. It’s been a little bit so maybe with a fresh mind, I can approach this challenge again.

If you have any resources, I’ll gladly read over them

Well, run the app with local development server and see what is not working. I am pretty sure problems you will have are already answered in this forum.

You know, coming back to this, and through some trial and error, I realized that while I was using the correct versions of Node and NPM in relation to the version of meteor, I realized it wasn’t meteor which was the issue regarding updating meteor, it was the fact that I was using yarn (or a current version of yarn) to manage packages and attempting updates
Using npm instead of yarn is allowing me to update from to and it works, which is the first step in my challenge! On to and on until I reach 1.8 at the very least!

Thank you for your help!

Just to cover all bases, this might be part of the problem: