Weird output in console on windows

For some reason when I run commands that require the meteor application to build packages i get some really weird stuff happening on my console on windows.
(link to screen shot of what happens)

It seems to be the spinning line that causes it to happen.
Instead of spinning on the spot it reprints stuff and goes up the console and any logging information that does get printed ends up getting covered over

looks to be more specifically during the Preparing project spinny loader

its rather useless.

Anyone know what i can do to fix this (short of using a mac/linux as it only happens on the windows machine for me)

Is that PowerShell? I seem to recall something like that. You could try cmd.

Happens in cmd, powershell, visual codes console(which is powershell also) and console2

Check the linked issue below for what were once work-arounds for this (and maybe still necessary?), and make sure you’re using a version of Meteor which contains the fix ( or higher).

You could also try setting the METEOR_HEADLESS environment variable to true – we do this in headless environments like CircleCI where the spinner is useless.

If the problem still occurs, we’d really appreciate some (Windows-user) help debugging it and fixing it, without losing the spinner completely! (more info: Developing Meteor itself)

I use Meteor in native Windows (PowerShell and cmd.exe), Bash on Ubuntu on Windows and also native Ubuntu. I saw this issue (or one very like it) back in the day under PowerShell, but I’ve not seen it recently anywhere.

I’ll check out those work around.

I’m currently using meteor 1.5 and it only started happening a couple of
versions before , can’t say exactly which version but it is only recent.

Is there any possibility you have a code page in your Windows environment?

Have you tried entering Unicode characters in the console to see if they render correctly?

I’m using the standard code page for windows 10, whatever it may be, as I have never changed it.
which seems to be 437 according to running chcp in cmd.exe

I entered some random unicode via keyboard, and most of it rendered correctly, but some did some weird things. missing glyphs showed the white square, but would also cause the cursor to overlap and some player up with the cursor spacing.
so its definitely part of it.

Rarely happens also with ConEmu. meteor reset fixes it.