What changes should I make to package.js after 1.2?


#1

Right now the package.js file in dalgard:viewmodel contains the following lines:

api.versionsFrom("METEOR@1.1.0.3");
api.use("grigio:babel@0.1.7");

Should I change something now that Meteor 1.2 supports ES2015?


#2
api.versionsFrom('METEOR@1.2.0.1');
api.use('ecmascript');

Get rid of grigio:babel entirely.

I was going to recommend using METEOR@1.2, but I’m not sure if that’s a valid format for the version number.


#3

But then, doesn’t my package force people to use Meteor 1.2 without any good reason?

(I know that people ought to update, but if they have an old project they don’t want to touch, but still want to use the newest version of my package … wait, I guess, I’ve answered my own question – if they are actually using an old version, they need the grigio:babel package as well.)


#4

ecmascript only works with Meteor 1.2 and up. So I’d say your options are, stick with requiring 1.1.0.3 and up, and use grigio:babel, or go 1.2 and use ecmascript.