When add new version of Cordova 3rd party plugin, failed to run on iOS and Android


#1

We have built up a Cordova plugin by ourselves, updated the old version 0.0.1 to new version 0.0.2 and publish to plugins.cordova.io with success. When we are using the 0.0.1 version by adding to meteor, everything is fine, we can build iOS and Android and tuning in emulation and physical devices. We remove the old version from meteor and add a new 0.0.2 version, then we met a problem when run the app and we got the following message on meteor terminal.

ritekiMacBook-Air:bllc char$ meteor add cordova:com.infapp.plugin.gizwitsandroid@0.0.2
added cordova plugin com.infapp.plugin.gizwitsandroid
ritekiMacBook-Air:bllc char$ meteor run android
Error while running for mobile platforms: Error running
/Users/char/.meteor/packages/meteor-tool/.1.0.45.1y6cwq8++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/cordova-scripts/cordova.sh
Error: version not found: com.infapp.plugin.gizwitsandroid@0.0.2
at
/Users/char/.meteor/packages/meteor-tool/.1.0.45.1y6cwq8++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/lib/node_modules/cordova/node_modules/cordova-lib/node_modules/npm/lib/cache/add-named.js:125:12
at RegClient.get_
(/Users/char/.meteor/packages/meteor-tool/.1.0.45.1y6cwq8++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/lib/node_modules/cordova/node_modules/cordova-lib/node_modules/npm/node_modules/npm-registry-client/lib/get.js:130:14)
at RegClient.
(/Users/char/.meteor/packages/meteor-tool/.1.0.45.1y6cwq8++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/lib/node_modules/cordova/node_modules/cordova-lib/node_modules/npm/node_modules/npm-registry-client/lib/get.js:49:12)
at evalmachine.:272:14
at
/Users/char/.meteor/packages/meteor-tool/.1.0.45.1y6cwq8++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/lib/node_modules/cordova/node_modules/cordova-lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:102:5
at Object.oncomplete (evalmachine.:108:15)

Fetching plugin “com.infapp.plugin.gizwitsandroid@0.0.2” via plugin registry

ritekiMacBook-Air:bllc char$

We have tried to reset the meteor, the same problem. It seems meteor didn’t update the cache. And we are trying to solve it manually.


#2

Do you mean meteor reset you can also try doing

rm -rf .meteor/local/cordova-build/
rm -rf .meteor/local/build/

can solve most of the plugin problems


#3

Thanks reku, I have solved the problem by manually delete the plugin cache folder under ~/.meteor/android_bundle/.npm/, add the package again in meteor, it works anyway.