Where do i start?


#1

I just downloaded meteor on my HP along with chocolatey and the things that come with chocolatey. Where do i go to start coding? can i just go on my notepad on the PC or is there more to it. where do i go im confused.


#2

In a terminal, go to the directory where you want your new app to be and type (using a better name than my-new-app):

meteor create my-new-app

If it creates a new app, then it’ll give you instructions from there. If not, there’s still some set-up to do.

Start the app as per the instructions then, in a browser, go to wherever the app is running (usually http://localhost:3000/).

To write code, download VS Code as your editor – it’s free and it’s pretty awesome.

Use VS Code to add a workspace and add your app directory, then you can start editing (and saving) the few sample files that constitute your app by default and watch the live updates happen in the browser window.


#3

www.meteor-tuts.com to kickstart your adventure into Meteor.

We recently shifted from WebStorm to VSCode and found out that VSCode with some plugins can be nearly as powerful as it, and it’s FREE! We no longer have to pay yearly licenses and it’s much much snappier.

So go download https://code.visualstudio.com/ and install the Meteor plugin.


#4

Follow Meteor Guide - https://guide.meteor.com/ - That will be good place to start


#5

Hi @babrahams,

I installed meteor on Windows 10 using choco. When I go to meteor create my-new-app, it gives me this error. It seems to reference a tools directory at C:\tools\tool-env\ . That doesn’t exist on my computer.

I’ve rebooted (as suggested here)… to no avail.

Any help would be appreciated. Thanks.
Jug

module.js:538
    throw err;
    ^

Error: Cannot find module 'internal/util/types'
    at Function.Module._resolveFilename (module.js:536:15)
    at Function.Module._load (module.js:466:25)
    at Module.require (module.js:579:17)
    at require (internal/module.js:11:18)
    at evalmachine.<anonymous>:31:26
    at Object.<anonymous> (C:\Users\jugster\node_modules\npm\node_modules\graceful-fs\fs.js:11:1)
    at Module._compile (module.js:635:30)
    at Object.Module._extensions..js (module.js:646:10)
    at Module.load (module.js:554:32)
    at Module.Mp.load (C:\tools\tool-env\install-runtime.js:16:29)

#6

Are you sure nodejs, npm are installed correctly on your machine ?


#7

Well I had the latest npm and nodejs(8.9.3). The issue I posted got solved by moving the .meteor directory to c:\code.meteor and updating the PATH environmental variable.
Edit: I followed this downloading the x64 version and it still didn’t work. So I tried moving the .meteor directory.

Was puzzled by that and soon I ran into another strange error - c:\Program Files\git\cmd\git.exe ls-remote was not working… I googled that and found someone suggesting using C:\Progra~1 instead of C:\Program Files in the PATH variable. That fixed the git ls-remote problem!

Its fixed now, but it seems like a strange error. Super thankful for your response! I appreciate it :slight_smile:

PS: I’ve since downgraded npm to 5.0.4 because of an issue unrelated to Meteor. I’m installing reaction which is built on top of meteor… and the install wouldn’t work till I downgraded npm.


#8

latest meteor tutorials with GraphQL & React - https://www.youtube.com/playlist?list=PLLnpHn493BHFTDL9M1PKnxQwBwOZ8J-h4


#9

checkout leveluptuts.

also, get a mac.