Why is deploying so hard? Will it get better?


#1

One thing that has bothered me a bit about the Meteor stack is how difficult deployment can become!

I’ve been playing around for the better part of a year now and love it.
The only thing that always gets me caught up is deployment.
What I don’t understand is why the functionality of MUP isn’t rolled into the Meteor dev tool?

Why can I run my dev. environment 100% without issues, but when deploying after updating the version it almost feels like I am rolling a dice.

I mentioned I have had issues with deployment.
Very early on it took me a solid couple of days to get deployment working on Digital Ocean.
Once it was working I was fine, pushed updates regularly - no issues and I was happy!
Updated to v1.2 and now my deployments are failing… I think it has to do with the node version I am using, but haven’t had time to really work on it.

My question is - is there room to improve and simplify the deployment of Meteor apps?


Why does the MDG group not talk about which version of node to use?
#2

Let’s hope Galaxy plans won’t be too taxing)


#3

@cstrat open up your mup.json file, change "nodeVersion": "0.10.36" to "0.10.40". Run mup stop -> mup setup -> mup deploy and your done. I wouldn’t say it was that hard! :smile:


#4

The only step in that which I didn’t try is first running mup stop … if that is it I am going to face palm so hard…

Will give it a try on the weekend, I can’t try it today :smile:


#5

Ok so I had a chance to work through the deployment issue.
I worked it out.

It is still a confusing process for which I think there needs to be more guidance for beginners to node & meteor.


The issue for me was the version of node - but it had nothing to do with my mup.json config.

My mup.json correctly said 0.10.40 - however I had installed node directly on the sever at some point very early on in my meteor learnings and set it up at 0.10.36.
It appears that if node is already installed on the server, mup doesn’t actually install node at all.

The fix for me was running this on the server:

% sudo n 0.10.40

This updated my node version on the server.
My mup.json config made no difference…

This might be clear to people but it was not clear to me.

It would be awesome if mup maybe checked the version on the server against the one in the mup config to warn the user or something?