Will multiple meteor apps deployed with MUP on the same server clobber each other?


#1

Currently, I have a number of Meteor apps all deployed on individual servers.

I plan to put all of them on a single server with nginx installed.

At the moment, my apps are all deployed using MUP and I plan to continue to do this.

In the MUP.JSON file, I specify things such as the Node version.

With these apps, some of them are actively maintained and some of them are not. So it’s entirely possible, that in the future, when Meteor 1.4 comes out for example, they’ll need different versions of Node to run.

My question is if I run mup setup on one app, will it affect the set up of another existing app on that server?

So for example, if I run mup setup on a new Meteor 1.4 app that needs node 4, will it upgrade the version of node on the server leaving all the other non 1.4 apps on the server to not be able to run? Or will it install node 4 alongside any other existing versions of node?


#2

If you use mupx (which you should, in my opinion) it creates separate docker containers for each app as far as I know. In which case you should be fine.

I’m afraid I can’t answer your questions on the other versions of node, but I know you can specify the node version in the mupx json file. I suppose you could setup a cheap $5 DO droplet for a day and give it a test with different node versions? That might be the best option.


#3

I guess in the long term I will be trying to use mupx but for the life of me, I haven’t been able to get it working.

How about this question? Do you know if MUP and MUPX apps can run on the same server?


#4

I think so. I don’t see any reason why they would interfere with each other.

How come you couldn’t get MUPX working? Are you running a DO droplet? I found I needed to have an updated kernel to get MUPX working as docker needs a fairly recent kernel version.


#5

tell you the truth, I don’t actually remember why. I just remembered it wasn’t straight forward and I spent like days on it and then I gave up because MUP just worked. I mean, technically I shouldn’t even need to change the mup.json file…

But I agree though - containers are the way to go so I’ll need to get MUPX sorted at some point when I have time to sort it out.

It could have been a kernel issue. I’m running a Azure ubuntu 14.04 LTS VM. I’m unaware of how droplets work - is that just another term for a virtual machine?


#6

It’s just a DigitalOcean droplet, their naming convention for setting up a host server with them. Check your kernel type on Azure with uname -r. If it’s older than 3.10 then that’s your issue with mupx.

In general I would recommend running a recent kernel anyway, but I don’t know how easy (or if it’s possible) to run a kernel update on Azure. I know you can with DO, however.

I hope all this has helped in some way anyway!