Windows 10 and 1.3.1


#1

After trying the numerous versions of the %appdata% folder deletes, uninstalling multiple times and reinstalling, deleting the entire local.meteor folder, I still can’t meteor create myapp on Windows 10 therefore there is no app to meteor update --release 1.3.1 on.

The above did work on my Windows 7 machine and I’ve had no trouble on my Linux Mint machines. It’s just this Windows 10 machine that is giving me fits!

Anything else I can try to get to where I can meteor create myapp in order to do the rest? meteor by itself tells me I’m not in an app folder, meteor create myapp hangs, meteor update --release 1.3.1 hangs.

I think I got all of that correct as far as the responses and behavior.

At my wits end because in my office I can only run the Windows 10 machine. Working on getting a mac notebook loaner since the network guys won’t support linux clients and therefore I have no enterprise connectivity.


#2

Nolapete, could you try pulling a project down from a git repo and then trying the folder delete/renew then?


#3

Sure thing, I’ll do that in the morning when I’m back in my office and let you know if that resolves it. A git repo slipped my mind. I was trying to figure out how I could get one of my own to work, but I don’t have any full working out anywhere, just my specific source files.


#4

pulled the blaze tutorial repo down and every command involving meteor hangs except meteor when run outside app folder. Uggh!


#5

i tried to create app in different angle… i used meteor create myapp --release 1.3
it worked fine…
after i tried to meteor update and whola its updated to meteor 1.3.1.
try that i use windows 10


#6

Meteor create myapp --release 1.3 crashes on Windows 10 while downloading meteor-tool
1.3.1.


#7

Sadly, on mine, meteor create myapp --release 1.3 just hangs. I waited over 30 minutes and no sign of life.

I’m skeptical that 1.3.1 actually fixed 1.3 on Windows 10. Other Windows versions, such as 7 that I have on my other machine, seem to be working now.

Very frustrated with this, especially considering 1.3 works well on my Linux machines.


#8

I had to uninstall, download and re-install. Make sure your AppData\Local.meteor is clean.


#9

uninstalled

went through and looked for leftover meteor files and got rid of them (found in local\Temp\somenpmfolderwithnumberafter)

deleted installer
downloaded installer
ran installer
(attempted developer login, but still get login failed message)

cd %appdata%
cd …\local.meteor\packages
rd /s /q templating (then same for standard-minifier-css, ecmascript, and templating-tools)

cd simple-todos (cloned git repo)
meteor update --release 1.3.1

nothing, but still waiting

tried just meteor in another app folder

nothing, but still waiting

UGGH!


#10

My Update to Meteor 1.3 has worked

  1. uninstalled meteor
  2. Freed up memory on windows system
  3. unzipped Github meteor to C:\Users\myName\AppData\Local.meteor
  4. Set environmental variables path to match 4)from a 1.2 meteor app file ran meteor update from admin command line
    5)meteor-tool@1.1.10 downloaded(20 minutes) downloaded packages
    Meteor-tool@1.3.1 downloaded (30 min) downloaded packages including webapp 1.2.7, templating 1.1.8 etc
  • now working -

#11

Is there any message indicating the downloads are happening?

Also, is yours Windows 10?


#12

Windows Version 10.0.10586
X64-based PC
Intel®Pentium®
Until I 'uninstalled apps you don’t use anymore’
and ‘Deleted Temporary files’ as per Microsoft’s
instructions ,
I would get 'downloading meteor-tools@1.1.10’
then in 5 minutes the computer would crash.

After freeing up memory - It downloaded meteor-tools@1.1.10 with a percentage marker, then
said ‘downloading’ for 20 minutes or so then said
’loading packages’ then repeated this for meteor-tools-1.3.1 , for 30 minutes, then loaded packages for 10 more minutes. Then listed all the new package versions (which now are in the versions file in my ‘app’)also the release file now says Meteor@1.3.1

Mayby it needed the extra memory or maybe the download was fixed.


#13

Still no dice. I even tried the Windows subsystem for Linux and got all kinds of symlink errors initially then mounted c and it just hung. I’m inclined to avoid Windows 10 and Meteor 1.3 at this point. Good thing I can still develop on my Linux machines.


#14

How long did you wait? Have you solved this issue, because I have the same


#15

Multiple times from 20 minutes to overnight and varying other times. Nothing has worked.


#16

I used https://github.com/meteor/meteor/releases
this worked in Windows 10 as detailed above

Since I am a beginner this left me without
tutorials that I can follow. Has anyone found
Chat-app and or google-maps tutorials in
meteor 1.3 ? -Phil


#17

HOORAY! I had stepped away from dealing with this issue, since it had me highly irritated. Yesterday, I decided to try again. I rm -rf the .meteor folder under %appdata%\local and it still didn’t work. Checked add/remove programs and uninstalled meteor there. Reinstalled it. Tried again and still didn’t work. Tried meteor create myapp --release 1.3 and while that still didn’t work, it did show some activity instead of just hanging. Tried meteor update in the simple-todos repo I cloned from github and VOILA! Activity like normal and when it was done the simple-todos app worked. Did meteor create myapp and that worked as normal too. HAPPY HAPPY!!!


#18

Back to Meteor not working on Windows 10. One update, one reboot, boom dead. Could we at least have the meteor update command check for OS and give an opt out message or proceed with “we don’t know WTF will happen if you’re on Windows 10!” message that allows you to have to the chance not to update? Come on MDG, you’re better than this bull!