Windows 8.1. meteor run andrid

i am still - after months of building an meteor app - trying to actually publish it into google play (and of course i thought i would easily make it an iphone app, ohboy, hahahaaaa) and well, this is now my third day, i am not even close to publishing android. what i did so far:

type meteor add-platform:
it tthrows an error, i find that one has to manually create a certain folder in the depths of the file system and run a dubious install command.

then i installled a few things and well - plattform android was added. 1.5 days. and not of the most fun kind.

you know - if you think 'why don’t you do something else instead??'
I WORKED ON THIS APP FOR MONTHS NOW AND NOT TO HAVE IT SIT ON MY LOCALHOST SO I CAN SHOW IT TO MY FRIENDS ON MY LAPTOP!!! so should i discard this work? or go through this hell of meteor publishing?

then i type meteor run android.

no error, but no emulator, only a spinning -.
nice. hours of fiddling, googling. then: i have to run android studio’s hyperflux manager or something and then change the BIOS!!! haha, i do it, i am a hero, i like it, it’s like a strange adventure game. so now, i can open an emulator in android studio, so i think HA!! and type meteor run android.

and i get this nasty son of a bitch message.
any ideas???

(and in general dear meteor team: take the windows version down. don’t tell anyone that you built something useful for windows 8.
and maybe you want to please reprogram my app into a technology that works. it’s really great and it should be launched!!!)


C:\Users\ma-ia\LongevityBasics>meteor run android
throw error;

Error: unexpected eof
at decorate (C:\Users\ma-ia\AppData\Local.meteor\packages\meteor-tool\1.4.1
at Extract.Abstract.error (C:\Users\ma-ia\AppData\Local.meteor\packages\met
at Extract._streamEnd (C:\Users\ma-ia\AppData\Local.meteor\packages\meteor-
at BlockStream. (C:\Users\ma-ia\AppData\Local.meteor\packages\me
at emitNone (events.js:67:13)
at BlockStream.emit (events.js:166:7)
at BlockStream._emitChunk (C:\Users\ma-ia\AppData\Local.meteor\packages\met
at BlockStream.resume (C:\Users\ma-ia\AppData\Local.meteor\packages\meteor-
at Extract.Reader.resume (C:\Users\ma-ia\AppData\Local.meteor\packages\mete
at Entry. (C:\Users\ma-ia\AppData\Local.meteor\packages\meteor-t
at emitNone (events.js:67:13)
at Entry.emit (events.js:166:7)
at Entry.resume (C:\Users\ma-ia\AppData\Local.meteor\packages\meteor-tool\1
at FileWriter. (C:\Users\ma-ia\AppData\Local.meteor\packages\met
at emitNone (events.js:67:13)
at FileWriter.emit (events.js:166:7)
at WriteStream. (C:\Users\ma-ia\AppData\Local.meteor\packages\me
at emitOne (events.js:77:13)
at WriteStream.emit (events.js:169:7)
at C:\Users\ma-ia\AppData\Local.meteor\packages\meteor-tool\1.4.1_2\mt-os.w
at C:\Users\ma-ia\AppData\Local.meteor\packages\meteor-tool\1.4.1_2\mt-os.w
at C:\Users\ma-ia\AppData\Local.meteor\packages\meteor-tool\1.4.1_2\mt-os.w
at FSReqWrap.oncomplete (fs.js:82:15)


Have you installed the required Android toolset?

PS: Could you please remove your other two posts on this forum with the exact same content? This would allow the community to focus on one of them. Thanks.

hi waldgeist, yes i have. and i found the secret avd manager in android studio and made the necessary changes in the … BIOS!!! which wouldn’t be such a big thing if somebody wrote that in the how-to-somewhere.
without hints this will keep you busy for a few hours.

and no, i can’t put them down yet, i need to increase visibility, when i posted the first time, i got 0! replies on my post. well somebody said “buy a mac”, but that was in another post.

so, i hope the community can handle the redundancy for now, while it increases my chance to actually get my app to work. but thanks for taking the time to write back.

oh - and if there was a “report issue” link somewhere this could be more focused.

Typically, you won’t need to do any BIOS settings. The only settings I am aware of is those that allow virtual machines to run on the actual hardware instead of simulating the processor. This increases emulator speed drastically, but only if you use the Intel version of an AVD. And typically, this setting is already active in the BIOS, at least it was for me.

Regarding post visibility: I doubt you will get more attention if you multiply your posts. On the contrary, it could be considered as being a bit annoying. Please keep in mind that the community here is replying to such questions voluntarily, most of us are just Meteor users like you and not related to Meteor Development Group.

Regarding “buy a mac”: In fact, I learned that this really helps. :slight_smile: I used to be a Windows guy for a long time, but development is way easier on a Mac system, not only for Meteor. BTW: Did you know that it is quite easy to install MacOS on Windows machines using VMware, without any costs? Just google it. I used this setup when my Mac was in repair, and turned out to work quite well. This is also a way to build an iOS app even if you don’t own a Mac. Yep, I know this using a VM does not feel as comfortable as developing natively on Windows. But in fact it turns out that many tools (like Node) “just work” on Mac or Ubuntu, while using them on Windows, well, rather painful. Maybe this will change now, given that Microsoft has included an Ubuntu subsystem in the most recent Windows version.

Issues can be filed here:

But please don’t flood this with questions that could be answered by RTFM :slight_smile:

And keep in mind that there is this very excellent Meteor guide:

i don’t know what to say.

meteor add-platform android – doesn’t work

meteor run android doesn’t work

and it’s fine that you don’t know about necessary bios changes, but how is this relevant for me. i had to change my bios. and if the excellent meteor guide (wow, you think after 3 days of trying to get this to work it helps if you post this url?!) was so excellent it would tell you. and not the 23rd page on google “windows 8 meteor.js android emulator not opening”.

i appreciate you writing back, but you’re not helping.

You got a strange way of asking for help, dude :wink: