Windows error in meteor


#1

I am getting the following error when creating or running a meteor app.

PS C:\Users\path> meteor
C:\Users\path> \AppData\Local\.meteor\packages\meteor-tool\1.6.1_1\mt-os.windows.x86_64\dev_bundle\lib\node_modules\meteor-promise\promise_server.js:218
      throw error;
      ^

Error: UNKNOWN: unknown error, lstat 'C:\Users\path\.meteor\local\dev_bundle'
    at Object.fs.lstatSync (fs.js:941:11)
    at Object.lstatSync (C:\Users\path\AppData\Local\.meteor\packages\meteor-tool\1.6.1_1\mt-os.windows.x86_64\dev_bundle\lib\node_modules\npm\node_modules\graceful-fs\polyfills.js:297:22)
    at exports.readLink (C:\tools\cli\dev-bundle-links.js:29:17)
    at exports.ReleaseFile.ensureDevBundleLink (C:\tools\project-context.js:1499:25)
    at exports.ReleaseFile._readFile (C:\tools\project-context.js:1442:10)
    at new exports.ReleaseFile (C:\tools\project-context.js:1392:8)
    at C:\tools\cli\main.js:924:22
PS C:\Users\path>

I reinstall meteor using choco same problem. Perhaps I need to to a clean install, not sure how. I noticed this happened after I installed the Windows 1803 build not sure if this is the issue.


#2

Hi, can u try using the Linux bash shell on Windows ?
It seems there is a problem with the April update. Me too, after the update I couldn’t start my meteor applications, even the new ones I created ( Error: Cannot find module ‘fibers’ ).
The solution I found is to use the bash, install nodejs, mongodb, meteor and it worked fine for me.
I don’t know if it’s an issue with Meteor or Windows 10.


#3

I was hope I wouldn’t have too. I can run meteor in bash but I don’t want too ;(. But I’ll try to install nodejs and mongo to see if it helps. How to access native windows directories within bash?


#4

You try to avoid that as best as you can. You’ll get very weird issues with file-locking and symlinks if you simply naively access the meteor project directory from within bash. Believe me, I went that route.

That said, here’s how you best go about it if you also want stuff like Git to work properly:
Every Windows drive can be accessed from within bash under their mountpoints, like /mnt/c/Users/...
Theoretically you can do it the other way around but don’t do that. At best you’ll run into errors, at worst you’ll make the subsystem unusable.

Now you install Meteor into the Linux subsystem like normal (been a while but I’d suggest doing an apt-get install build-essential first, though).
Then you create your Meteor project, either by cloning it through Git or like normal.

Now comes the annoying part: You have to create a bunch of symlinks. Basically, every folder and file you create or modify as a user has to be symlinked so that the files and folders still exist in Windows but only as a symlink in the subsystem.
You thus symlink everything except the local folder inside the .meteor folder. In principle you could probably get away with not linking node_modules but if you’re using Typescript you better link it as well.


#5

I am very concerned about this. I do not think it is feasable to run the ubuntu version. I spent the day assuming this was some config or dependancy error on my part and plumbed the webstorm debugger to uncover the issue in fs.js 1670:17 - which led me down another rabbit hole of setting read-attribute rights on 3 directories (recursively). All to arrive at this punchline of a forum post when everything I tried failed (also tried on a clean machine).

So what is the current state of this bug? Is the windows update permanent? Is there a windows or meteor patch in the works? Can someone explain the details of how windows broke meteor?

Thanks!


#6

Is there a way to use vagrant box or is it similar to WSL?