Zoom with zoomooz.js

hi team,

I would like to use zoomooz to zoom in my html. I already tried to put in the in the compatibility folder and I tried to import the NPM module, but maybe I do this incorrectly…

import 'zoomooz';

So maybe I am importing it incorrectly? I do not see an export statement in the source


1 Like

If it’s in your compatability folder, you can just start using it in your code without any imports

thanks, I tried that too nothing works. I don’t get errors, the text does move, but no zoom. I created a repo (using the compatibility folder) https://github.com/QHose/zoomooz

It would be really cool if we can all use this…

Mmm, other Zoom tools also Not work. So I guess i have css conflicts… should i do a Css reset?

mmm, I now see meteor 1.5 uses a very old jquery? (Or should I update it manually?) that can explain why things don’t move on my screen (they need jquery 1.7 +)

EDIT: you can put the correct version of jquery in the client\compatibility folder

Ahh, a jQuery version problem!

To fix those just install the npm version of jQuery and Meteor will use that instead of the old version that’s bundled with it.
Run this instead of including jQuery in your compatability folder:

meteor npm install --save jquery

thanks, but if I do that I noticed that packages like semantic (Which add extra functions to $ ) don;t work anymore, because we overwrite $ with “clean” jquery at the end?

Should’t make any difference because ‘meteor/jquery’ either loads npm jQuery if available before loading the bundled version. i.e. the load order is identical between built-in jQuery and meteor’s jQuery.

Easiest way to be certain is to add an explicit import before importing the plugin:

import { $ } from 'meteor/jquery';

Mmm, i know i tried this, and i am pretty Sure i got failures with Semantic ui (that uses jquery selectors, eg i got $[].xyz is Not a function… ) Use newer version of jquery?