Can not find module './utils.js' error


#1

After I create a new project and run it, it get lots of error in console.please help
I’ve sent

meteor npm install


Sample project "welcome home page" is not right
#2

You should try to follow the link at at index.js (modules.js..... on line 4, and see if that is in your project. Does utils.js exist in the same directory as that index.js file?


#3

I find the link at

.meteor\local\dev_bundle\lib\node_modules\reify\lib\runtime

and utils.js file are next to index.js.
I have no idea why i just started a new project, and so many problems.
I tried reinstall meteor, recreate project, but all of these not work, please help.


#4

And you have done nothing but
meteor create myapp and meteor run? Have you added any files at all?
What version and operating system are you on?

I just created a new project and it worked fine.


#5

meteor create my-app-name
cd my-app-name
meteor npm install
meteor

=> Started proxy.
=> Meteor 1.5.2 is available. Update this project with ‘meteor update’.
=> Started MongoDB.
=> Started your app.
=> App running at: http://localhost:3000/
Type Control-C twice to stop.

Im use meteor 1.5.2, and my system is windows 10 64bit


#6

Sounds like a windows issue Like this

Try moving the project to your user directory, if it is not there already.


#7

I tried, but it still happend…
I also tried

meteor npm install --save babel-runtime

or

meteor reset