Cant install meteor through npm install - Windows server

Hi all,

I’m trying to install meteor@2.5 in Windows Server (2012 - Standard) but to no avail. This is what I do:

  1. I’m sure node (version 12) is installed
  2. Set proxy variables because this server is behind proxy
  3. run: $ npm install -g meteor@2.5.0 (apparently runs Ok, but no!)
  4. run: $ meteor create --release 2.5 --bare meteor-app

It says it is installing meteor@2.5, but wasn’t it installed before? Anyways it fails. Please see image.


  1. Why npm install fails, even when apparently it runs Ok?
  2. Why meteor create --release 2.5 can’t download meteor@2.5? It says there is no Internet. There is!

Note: I installed npm packages (node_modules) from a meteor app without any problems.

What am I doing wrong?

Many thanks for your help and bye …

I was wondering is there is another way to install meteor on Windows,
that is different to using:

  1. npm install -g meteor
  2. meteor update …

Thanks and bye …

It seems I can not download meteor from a Windows machine behind a proxy.
I could do this before, without any problems. Npm works without problems, though.

Thanks and bye …

Another replay by myself.

What I don’t get is why npm install -g meteor says meteor is already installed. Of course there are many versions installed, but not 2.6.1. Please take a look at the image:

Try with version 2.5.6, I think there might have been some fixes there. The proxy thing might be an issue. I wonder if you could try on Windows to use the command line install.

Hi @storyteller and thanks,

I’ll try with version 2.5.6 as soon as I can, which means later today.
I was wondering what do you mean by

… try on Windows to use the command line install.

Thanks again and bye …

1 Like

Hi all,

Well, I just tried to install version 2.5.6 as @storyteller suggested but with same results.

Then I executed just $ npm install -g meteor (without specific version) to try installing the brand new version of meteor: 2.7. The result is exactly the same:

$ npm install -g meteor
C:\Users\<userNameL>\AppData\Roaming\npm\meteor-installer -> C:\Users\<userNameL>\AppData\Roaming\npm\node_modules\meteor\cli.js

> meteor@2.7.0 install C:\Users\<userNameL>\AppData\Roaming\npm\node_modules\meteor
> node cli.js install

Meteor is already installed at C:\Users\<userNameL>\AppData\Local\.meteor
If you want to reinstall it, run:

  $ meteor-installer uninstall
  $ meteor-installer install

+ meteor@2.7.0
updated 1 package in 5.441s

Administrador@contaserver MINGW64 ~

What I think is the installation gets messed up somewhere and thinks meteor is already installed. Of course it is installed, but several different versions. Look at the message:

Meteor is already installed at C:\Users<userNameL>\AppData\Local.meteor

But, shouldn’t that path be:

I think for some reason the installer fails on Windows, maybe not in Linux.

Is there someway to tell the installer that the path is:
And not

Thanks …

What I’ve also found is that meteor-installer uninstall and meteor-installer install also do not work on Windows (I’m using Windows 11). I have to either remove or rename the .meteor directory and then install.

Did you try uninstalling first ?
npm -g uninstall meteor I don’t know if this work.

I had a similar issue on my end but on ubuntu, where I had an older version of meteor installed using the old method.

Did you try curl | sh

D:\MeteorProjects>npm -g uninstall meteor
removed 47 packages in 0.365s

But it doesn’t do anything, meteor is still there and still works.

I know this doesn’t apply to you in Windows: Install | Meteor API Docs

But have you tried to manually remove the folders?

@kheang, that is what I said I have to do. See above. :wink: I’m just pointing out that meteor-installer uninstall and meteor-installer install do not work, or I can’t get them to work. :wink:

1 Like

Stupid question but did you try to go to the AppData/Roaming/npm folder and execute meteor-installer uninstall ?

I am doing some tests on my Windows 10 home PC and at first it worked and then couldn’t find the PATH anymore so I had to manually type in the full path in order to run that executable to uninstall meteor.

I noticed that in Powershell when I type the full path, it opens a cmd prompt window to run it.
I also tested it in cmd window run as admin and it worked for me.

nothing for meteor exists there. But this walk down AppData/Roaming/ and AppData/Roaming/npm lane helped me delete about 3 gigs of unused stuff. :rofl:


That’s odd because on my PC i do have AppData/Roaming/npm/meteor-installer there.
That’s how I was able to uninstall it using that command.
Maybe if you do a search and find where meteor-installer is and type the full path it would work.

But just guessing.

I just looked at the meteor-installer file and all it does is execute the cli.js
So I tested with

node c:\Users\<user>\AppData\Roaming\npm\node_modules\meteor\cli.js uninstall

And that worked also.

Did a search for meteor-installer, nothing was found.

Hmmm… for me, Meteor doesn’t exist in C:\Users\<user>\AppData\Roaming\npm\node_modules instead it’s existing here: C:\Users\<user>\AppData\Local\.meteor.

Yeah I think the one in the Roaming/npm/node_modules is the installer.

What version of npm and node are you using?

I’m using node v14.16.1 because of the Meteor requirements for node.

Ok, I just updated my version of nvm (GitHub - coreybutler/nvm-windows: A node.js version management utility for Windows. Ironically written in Go.) and updated to the same version of node as you are using.
Ran npm install -g meteor and for some reason now its installing it from this location:

C:\Program Files\nodejs\meteor-installer -> C:\Program Files\nodejs\node_modules\meteor\cli.js

> meteor@2.7.0 install C:\Program Files\nodejs\node_modules\meteor
> node cli.js install

And after I was able to run meteor-installer uninstall also.

Well, that’s interesting. What version of node were you using before?