Core Dumped when attempting update from 1.8.2 to 1.9 (or above)

Thank you in advance for any assistance or direction you may be able to provide as I’m fairly new to meteor and have inherited a few applications.

I am currently in the process of updating a meteor application to the latest version but hit a snag at v1.9. Specifically, when I run “meteor update --release 1.9” (or any subsequent version) I am met with a fairly unhelpful error:

ematthews@ematthews-vm-mint:~/projects/website/junction$ meteor update --release 1.9
/home/ematthews/.meteor/packages/meteor-tool/.1.9.0.c4cpd0.8as8++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node[47368]: ../src/node_contextify.cc:649:static void node::contextify::ContextifyScript::New(const v8::FunctionCallbackInfo<v8::Value>&): Assertion `args[1]->IsString()' failed.
 1: 0x9da7c0 node::Abort() [/home/ematthews/.meteor/packages/meteor-tool/.1.9.0.c4cpd0.8as8++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
 2: 0x9da847  [/home/ematthews/.meteor/packages/meteor-tool/.1.9.0.c4cpd0.8as8++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
 3: 0x9ce1bf node::contextify::ContextifyScript::New(v8::FunctionCallbackInfo<v8::Value> const&) [/home/ematthews/.meteor/packages/meteor-tool/.1.9.0.c4cpd0.8as8++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
 4: 0xba701b  [/home/ematthews/.meteor/packages/meteor-tool/.1.9.0.c4cpd0.8as8++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
 5: 0xba7ba2 v8::internal::Builtin_HandleApiCall(int, unsigned long*, v8::internal::Isolate*) [/home/ematthews/.meteor/packages/meteor-tool/.1.9.0.c4cpd0.8as8++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
 6: 0x13750d9  [/home/ematthews/.meteor/packages/meteor-tool/.1.9.0.c4cpd0.8as8++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
Aborted (core dumped)

I’ve attempted to scour the internet for others running into a similar issue and haven’t had much luck. My suspicion is that there may be some conflict with some of the project dependencies as many of them are quite old; however, I haven’t been able to make much progress from attempting to comment out packages and retry as of yet.

Any solutions or even guidance on how to go about debugging this issue would be greatly appreciated!

Well, I was able to get my app to update to the current latest Meteor version, v1.10.2.

If anyone is curious, here are the steps I took to get it to work:

  1. Rename the “packages” folder to something else to temporarily “remove” the packages as far as Meteor is concerned.
  2. Comment out all entries for the now removed packages in the .meteor/packages file.
  3. Run ‘meteor update’
  4. Rename the “packages” folder back to “packages” and un-comment the packages
  5. Profit.

Still not sure which of the packages was causing issues or why it was preventing the update but hey, my app works and is now the most recent version so I’m not going to complain.

Hopefully this helps someone else in a similar situation!

1 Like

@ematthews Hey, Can you please explain more, How you have resolved this error?
I am facing same issue.

@hermenpreet, the issue was a result of one of the custom packages I had in my project (i.e., in the “packages” directory). I’m not sure which one had the issue, but essentially all I did was remove all the packages (or hide them from Meteor by changing the directory name), update to the latest version, then adding the packages back in.

Hope this helps! Good luck!