Deployment on galaxy issue

Hi,
I am running ,y app on local host with meteor --production and it works fine.
when i try to deploy it I get on the galaxy log:

Error: $ROOT_URL, if specified, must be an URL
d4dv
2016-02-25 23:31:17+02:00 at Error ()
d4dv
2016-02-25 23:31:17+02:00 at Meteor.absoluteUrl.options (packages/meteor/url_server.js:8:1)
d4dv
2016-02-25 23:31:17+02:00 at /app/bundle/programs/server/packages/meteor.js:1132:4
d4dv
2016-02-25 23:31:17+02:00 at /app/bundle/programs/server/packages/meteor.js:1274:3
d4dv
2016-02-25 23:31:17+02:00 at /app/bundle/programs/server/boot.js:242:10
d4dv
2016-02-25 23:31:17+02:00 at Array.forEach (native)
d4dv
2016-02-25 23:31:17+02:00 at Function..each..forEach (/app/bundle/programs/server/node_modules/underscore/underscore.js:79:11)

this is how my settings.json looks like and I was able to deploy it earlier.

{
galaxy.meteor.com”: {
“env”: {
“ROOT_URL”: “dev.domain.co.il”,
“MONGO_URL”: “mongodb://name:576767yhthhhth865.mongolab.com:55865/bla”
}
}
}

1 Like

try adding: http:// at the start of the ROOT_URL.

2 Likes

It worked ! :slightly_smiling:
weird it passed some previous es deployments.
Many thanks.

1 Like