Error after updating meteor to 1.3


#1

I just ram ‘meteor update’ to get 1.3 but now the meteor tool seems to be broken. I tried to start an existing project and also create a new project and I get the following:

C:\Users\tc\AppData\Local.meteor\packages\meteor-tool\1.3.0_3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\meteor-promise\promise_server.js:116
throw error;
^
SyntaxError: Unexpected token

I really, really would like to carry on working onmy project!!! Can anyone help.

ps I’m on Windows 10 if that is relevant, I heard support for this OS is not as uptodate as other platforms.

Cheers,
Tony


#2

I’m getting the same error, both on updating old apps and creating new apps. Any help would be great.
Windows 10 as well.


#3

I’m also receiving an error, although different, while creating a new project in Windows.

While loading plugin `compileTemplatesBatch` from package `templating`:
module.js:338:15: Cannot find module`
...

#4

Hi Nathan,
I am now getting the same error message as you on new projects. My existing project is still trashed with the original error though and not updating to 1.3. Seems like a pretty sh*tty update.
If I find anything I will let you know. I’m just trying on Linux out of curiosity.
Tony


#5

I can run old 1.2.1 projects, it asks me to update. Wont update anything else until this gets fixed.


#6

I suspect these bugs are not related to each other, though that’s kind of hard to tell when you omit useful information from your stack traces. Please file (separate) bugs on GitHub with complete stack traces, and then we might be able to help solve your problems. Thanks!


#7

Thanks Benjamin,

Seems to be Windows only. I just created a 1.3 project on Linux with no issues.

I’ll look at creating a bug report on git hub.

Tonyt


#8

Thanks Benjamn, I submitted the issue on github.


#9

Anyone have any luck fixing this issue? I’ve been beating my head against the screen all day.

C:\Users\Chris\AppData\Local\.meteor\packages\templating\1.1.7\plugin.compileTemplatesBatch.os\npm\node_modules\meteor\promise\node_modules\meteor\promise\node_modules\meteor-promise\promise_server.js:116
      throw error;
            ^
Error: Surprising path: /packages/modules.js

#10

i have the same error on osx:

/Users/<my-user>/.meteor/packages/meteor-tool/.1.3.0_3.y7lydj++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/isopackets/cordova-support/npm/node_modules/meteor/promise/node_modules/meteor-promise/promise_server.js:116

Error: ENOSPC, write

#11

“ENOSPC” means that there is no space on the drive. It may be that drive your tmp folder is in has run out.


#12

@M4v3R you’re just right, thank you so much!


#13

Well I got 1.3 working!
First I completely uninstalled meteor and deleted all remaining files. I reinstalled and got a new set of errors. I then deleted a bunch of packages that I found reference to in the repo issues. I got to the point where the app would start but error.

What fixed it for me was moving my .meteor folder out of my project, run it and got the use meteor create response. I then copied the folder back into the project and all is well… Last time I rush to update to a new release.


#14

Hi @briarfox,

Could you formalize your steps so that we can also repeat it as well, I am using Windows 7 64 bit Enterprise. But if deleting, then the Window installer will reinstall next time from 1.1 again? Because that was the starting point of the MSI install?


#15

Best solution is to remove meteor and freshinstall 1.3 from website, but you will get the issue @briarfox mentions.

Check https://github.com/meteor/meteor/issues/6609 for more info on that.
The problem is a series of REALLY long path names NTFS just can’t handle.
You gotta delete a few packages from your AppData/Local/.meteor/packages folder and you’re good to go again.

As mentioned in issue. Test on a real computer MDG! Not a VM!


#16

I created new meteor project. And I can not run meteor, it shows:
While loading plugin compileTemplatesBatch from package templating:
module.js:338:15: Cannot find module
’…/modules/es6.object.get-own-property-descriptor’
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\Anh\AppData\Local.meteor\packages\templating\1.1.7\plugin.compileTemplatesBatch.os\npm\node_modules\meteor\ecmascript-runtime\node_modules\meteor\ecmascript-runtime\node_modules\meteor-ecmascript-runtime\node_modules\core-js\es6\object.js:12:1)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)

Please support to resolve this issue.
I reinstalled several times, and tried to delete all folders in appData, temp.
This is really embarassing!!!


Can't upload apk to Play Store
#17

@Anhpham
Assuming you’re on Windows?
Uninstall meteor, then delete AppData/.meteor
Make sure it is all deleted! Double check using cmd.
There’s a bug with length of path names and windows’ NTFS

Then reinstall Meteor from the website(now 1.3)
Delete the folders mentioned in the githubissue I linked above.
Then you should be good to go :slight_smile:


#18

Thank you.
I’m on Windows 10 64bits. I tried to uninstall meteor and delete all files in appData, then installed meteor again.
However it keeps saying several errors when runing my existing project.
I have to create another one with “meteror create --release 1.2.1 myapp”, and copy its .meteor folder into my project. But it shows an error when I add “classcraft:googleapis”
`meteor add classcraft:googleapis

C:\Users\Anh\AppData\Local.meteor\packages\meteor-tool\1.1.10\mt-os.windows.x86_32\dev_bundle\lib\node_modules\fibers\future.js:278
throw(ex);
^
Error: ENOENT, open 'C:\Users\Anh\AppData\Local\Temp\mt-1lqdq20\os\classcraft:googleapis.js’
at Object.Future.wait (C:\Users\Anh\AppData\Local.meteor\packages\meteor-tool\1.1.10\mt-os.windows.x86_32\dev_bundle\lib\node_modules\fibers\future.js:398:15)
at C:\tools\fs\files.js:1331:28
at Object.wrapper [as open] (C:\tools\fs\files.js:1334:20)
at Object.files.readBufferWithLengthAndOffset (C:\tools\fs\files.js:1474:20)`

What should I do to use this package as usual?


#19

@sunrising What steps did you take to resolve this? Did you remove everything from your /tmp folder? If so, did you have to reinstall anything?


#20

Hi @townmulti,
as I was told there was not enough free space, so I just had to clean my hard disk… in fact, if I’m not wrong, i had less than 1Gb of free space.
It was something very simple to fix :slight_smile: , i hope this will do the job for you too.

have a nice day.