Exited with code: 3228369023

I’m trying to upgrade an old project from up to 2.5.3, currently only at v1.8.1 and getting this error:

Exited with code: 3228369023


Problem only starts to appear when I upgrade to this specific version, downgrading doesn’t fix it, if that info helps

Which MongoDB version are you using?

Can you try running meteor reset? It will erase your local Meteor cache and local MongoDB data.

Hi, thanks for the response.

I’m using mongdb v2.2.11. Tried reset and still having that problem.

Try to delete the folder of db: ./meteor/local/db

Tried it and still the same error, thank you for the suggestion though.

Oh, sorry, now I saw your mongodb started and the error was after it. Did you try remove all ./meteor/local folder?

If yes, maybe you need to come back with some versions before starting your app with the latest version.

Yep I tried deleting the local folder and still the same.

I came from been running upgrades and running the meteor app after every update and the problem only appeared on this specific version (1.8.1).

I need to update to the latest version though so we can leverage updated libraries

Try to back to 1.8, clear local folder, clear npm files (node_modules folder), and run your app. Just after that update to 1.8.1 and look at the changelog documentation to each version you are updating.

My general advice is to update version to version (I think you are doing this).

Thank you for the suggestion.

I actually did that already, quite a few times already but no success. Also the migration steps on 1.8.1 doesn’t have anything so I guess just the normal update command should work but not on my end.

I did decide to attempt to move to a higher version just to see if it would have the same problem and it did until version 1.9.2 (I upgraded one version at a time) where the initial error I’m getting is this:


Still trying to make it work, when I make it work and this new version doesn’t have that same exit code, I will update here, thanks again for the help!

Now is more clear. You need to solve the problem with this package (meteorhacks_meteorx). Many of the problems of updating Meteor version are packages that can’t work very well. This package is old, then you can try to remove it and install it again, or substitute it with another. You can look it for newer forks. I found this newer


Oh, I just realized now that I cut out the important part.

The error is triggered by the boot.js from .local/build/programs/server/boot.js

I don’t see meteorx referenced directly inside the package so I’m thinking it’s referenced by one of the packages or meteor itself did. Sorry I’m still new to debugging dependencies so thank you very much for your help.

Hi @raragao, you were right! I have been looking for meteorx when what we were using was meteorhacks:unblock which was depending on meteorx. I just added the lamhieu unblock package and it finally ran! Still not sure what the exit code meant but on version 1.9.2 it doesn’t show anymore when I start the server. Thank you very much for the help! Stay awesome! :slight_smile: