Galaxy hosting with www CNAME No applications registered


#1

I’m using Galaxy with CloudFlare as the DNS server.

I am deploying to mydomain.com and I want both www.mydomain.com and mydomain.com to work.

Now when I try to visit my site via www.mydomain.com it shows me this error:

404 Not Found: No applications registered for host ‘www.mydomain.com

I fixed this temporarily by deployed two instances of this app via www.mydomain.com and mydomain.com :confused:

Here is my DNS settings:

CNAME | mydomain.com | galaxy-ingress.meteor.com
CNAME | www          | mydomain.com

Here is my Galaxy ROOT_URL:

"ROOT_URL": "http://mydomain.com"

All advice appreciated! :slight_smile:


#2

I had the exact same problem !!

But I waited for a while and the dns propagated correctly :slight_smile: courtesy of @serkandurusoy


#3

I have had this DNS settings for a while but it is still not working… :confused:

CNAME | mydomain.com | galaxy-ingress.meteor.com
CNAME | www          | mydomain.com

You have the same?


#4

my one is a bit wired. I guess every dns server is different. In mine, I could only have cname for subdomains. So I added a subdomain called www just like yours and added the galaxy-ingress.meteor.com cname in there.


#5

This sounds like a different problem.

You should not be able to point mydomain.com with a CNAME record, I think that’s an invalid DNS entry. You should be using an A record that points to an IP address or a redirect (using other tools)

Take a look at this article:

https://galaxy.meteor.com/help/configuring-dns


#6

Ahhh I see.

So I need to configure something inside CloudFlare?

Here is my DNS settings btw:

So mydomain.com can’t be an CNAME you say?


#7

Well it is more intricate than that, but basically no, you cannot use a
cname for your domain root and have a separate record for www.

What you need to do is set up the cname record for www, delete the
cname record for the root, set up a www redirect using one of the
suggested ways (re: the galaxy dns help article)


#8

yap thats how I did mine. My root redirects to www subdomain and I have CName Set-up for that subdomain.


#9

Okay I’ll try that.

Thanks! :smiley:


#10

but galaxy doesnt give us an ip address?


#11

Oh that’s correct. So I guess the redirect should be solved otherwise :frowning: