GUI to Manage MongoDB from Digital Ocean


I have deployed an app on Digital Ocean, I want to be able to have some GUI manage the collections. On my localhost I use Robomongo, but I dont know how to connect Robomongo to Digital Ocean.

Does anyone use a GUI to manage their collections?

A free option. I see people us compose which is $18monthly.

If you can connect to you Digital Ocean Mongo instance remotely, you can use Robomongo as well with the same connection settings.
Are you getting any error messages when trying this?

1 Like

“error: Unable to connect to MongoDB”

Not 100% what my settings should to have it connected. I dont see instructions on how to connect robomongo remotely to OD.


YMMV, but this is the setup I use:

When you set up your droplet, create an ssh key.

Run your meteor instance, deploy with mup, etc…

To connect using robomongo, create a new connection with your ip address and mongo port (27017 by default). Then, in the connection settings window, head to the ‘ssh’ tab. Use your ip, 22 as the port, your ssh user name (root), auth method: private key, and then find your private key and paste the location in. Depending on whether you set up a passphrase, enter it also…

Hope this helps!

If you search this forum, you’ll find this:

I use robomongo with a project in digital ocean and connect by SSH:
Connection tab:

  • Address:
  • Port: 27017

SSH tab:

  • SSH address: your droplet IP:22
  • The SSH username and password

manrashids way is how I do it, It tunnels you through SSH and then connects you via loopback so you don’t have to worry about allowing access from another interface.

no still cant connect.

is SSH address my domain or ip address?

Is address suppose to be or my ip address?

no still not working. tried with and without http:// infront of ip address in the ssh settings.

You can always give MongoChef a try, if you give up on Robomongo :slight_smile: I did that myself a few months back. Can’t help you with your problem though, I’ve only ever connected remotely to Compose, which was straight forward…

Are you exposing your DB on a particular port? - beyond getting the right port and server address, it shouldn’t be any harder than passing authentication you’ve setup for yourself…

or he can run Dr.Mongo in separate docker there :smiley:

1 Like

What version of Mongo is being used on Digital Ocean? - Robomongo does not support version 3

No prob with Robomongo on digitalocean for me. Unless u post screenshot of what u did, I’m afraid I can’t help u.

1 Like

I dont know how o check if it is on a particular port. downloading Mongochef as suggested.

Since you have deployed on DO. You must be accessing it using userid/password or ssh keys.
On RoboMongo on setting connection options, use SSH tab with ssh tunnel tunnel. use the userid/password with password option. if you have keys, I have found that private key selection causes problem, instead copy the complete path where the keys are located and paste in the box - for me that has worked.

Failed to connect to the SSH server. Publickey authentication failed.

balls. this is annoying.

feck sake. i just remved the ssh key from DO. wISH They would just make a step by step guide how to do this.

made new ssh keys. still not working.

Failed to verify connectivity with the server.

come on man give us a break. i just spent ages installing it and i have no clue what i suspose to put in the new connection tabs.

So it bothered me that you haven’t been able to get this to work. I just tried duplicating the exact same connection I’ve been using for months on robomongo and I haven’t been able to get it to work. As a workaround, try this:

ssh -L 4001:localhost:27017 root@your.drop.let.ip

localhost:27017 is the location of the mongo instance running on your droplet, so if you’ve changed the port or are running the meteor command directly (which puts the mongo at 3001) you will have to change this.

4001 is the port you want to forward to on your local machine. Then, you can use your robomongo to connect to localhost:4001, and the connection will be tunneled over ssh, giving you access to your remote db. I just tried this with the same connection and it worked right away. Let me know if this doesn’t help…

1 Like

On my guest I removed the SSH to put in a new one. Then realised you cant add a SSH to a droplet after droplet launched. Then my MUP wouldnt deploy. So I messed up the project big style.

So I made a new droplet. Luckily the project isnt publicly launched yet so it doesnt matter about losing all the data.

Still dont have a GUI for Mongo.