Help deploying meteor app with galaxy


#1

So, I can see the application in the galaxy panel, however when i visit the domain it says " no domain ", in the guide, they mention that

" simply add a CNAME record to your DNS provider pointing to galaxy-ingress.meteor.com "

So, I’ve done this… is there any other changes that I should make in order to be able to see my application in the browser ? I just bought the domain today on godaddy,com and this is my first time ever buying a domain name.


#2

Assuming your CNAME is setup properly, it can take time for your DNS changes to propagate across the interwebs. If you want to share the domain name or a screenshot showing your CNAME setup in GoDaddy, we can help further.


#3

so my domain name is www.sharedvolume.com

and here’s a screen shot of my CNAME setup :


#4

Your CNAME appears to be configured properly. I’m getting a Galaxy side 502 error when I access your domain:

502 Bad Gateway: Registered endpoints failed to handle the request.

Do you have everything configured properly on the Galaxy side?


#5

I followed the instructions on galaxy : Here’s what my settings file looks like

{
"oauth": {
     "google": {
         "clientId": "yourClientId",
         "secret": "yourSecret"
     },
     "github": {
         "clientId": "yourClientId",
         "secret": "yourSecret"
     },
   "facebook":{
     "clientId": "yourClientId",
     "secret": "yourSecret"
   }

 },
"galaxy.meteor.com": { "env": { "ROOT_URL": "https://www.sharedvolume.com", "MONGO_URL":     "mongodb://username:password@aws-us-east-1-portal.10.dblayer.com:10525/admin?ssl=true", "MONGO_OPLOG_URL": "mongodb://username:password@aws-us-east-1-portal.10.dblayer.com:10525/admin?ssl=true" } }
}

#6

Ahhh i have access to some logs that I didn’t notice ! Here are some of the errors i get !

2016-02-19 21:02:02+01:00MongoError: Authentication failed.
w9ad
2016-02-19 21:02:02+01:00 at Object.Future.wait (/app/bundle/programs/server/node_modules/fibers/future.js:398:15)
w9ad
2016-02-19 21:02:02+01:00 at new MongoConnection (packages/mongo/packages/mongo.js:221:1)
w9ad
2016-02-19 21:02:02+01:00 at new MongoInternals.RemoteCollectionDriver (packages/mongo/packages/mongo.js:3352:1)
w9ad
2016-02-19 21:02:02+01:00 at Object. (packages/mongo/packages/mongo.js:3386:1)
w9ad
2016-02-19 21:02:02+01:00 at Object.defaultRemoteCollectionDriver (packages/underscore/packages/underscore.js:779:1)
w9ad
2016-02-19 21:02:02+01:00 at new Mongo.Collection (packages/mongo/packages/mongo.js:3507:1)
w9ad
2016-02-19 21:02:02+01:00 at AccountsServer.AccountsCommon (accounts_common.js:23:18)
w9ad
2016-02-19 21:02:02+01:00 at new AccountsServer (accounts_server.js:16:5)
w9ad
2016-02-19 21:02:02+01:00 at Package (globals_server.js:5:12)
w9ad
2016-02-19 21:02:02+01:00 at /app/bundle/programs/server/packages/accounts-base.js:1814:4
w9ad
2016-02-19 21:02:02+01:00 - - - - -
w9ad
2016-02-19 21:02:02+01:00 at Object.toError (/app/bundle/programs/server/npm/npm-mongo/node_modules/mongodb/lib/mongodb/utils.js:114:11)
w9ad
2016-02-19 21:02:02+01:00 at /app/bundle/programs/server/npm/npm-mongo/node_modules/mongodb/lib/mongodb/db.js:1196:31
w9ad
2016-02-19 21:02:02+01:00 at /app/bundle/programs/server/npm/npm-mongo/node_modules/mongodb/lib/mongodb/db.js:1905:9
w9ad
2016-02-19 21:02:02+01:00 at Server.Base._callHandler (/app/bundle/programs/server/npm/npm-mongo/node_modules/mongodb/lib/mongodb/connection/base.js:453:41)
w9ad
2016-02-19 21:02:02+01:00 at /app/bundle/programs/server/npm/npm-mongo/node_modules/mongodb/lib/mongodb/connection/server.js:488:18
w9ad
2016-02-19 21:02:02+01:00 at [object Object].MongoReply.parseBody (/app/bundle/programs/server/npm/npm-mongo/node_modules/mongodb/lib/mongodb/responses/mongo_reply.js:68:5)
w9ad
2016-02-19 21:02:02+01:00 at [object Object]. (/app/bundle/programs/server/npm/npm-mongo/node_modules/mongodb/lib/mongodb/connection/server.js:446:20)
w9ad
2016-02-19 21:02:02+01:00 at [object Object].emit (events.js:95:17)
w9ad
2016-02-19 21:02:02+01:00 at [object Object]. (/app/bundle/programs/server/npm/npm-mongo/node_modules/mongodb/lib/mongodb/connection/connection_pool.js:207:13)
w9ad
2016-02-19 21:02:02+01:00 at [object Object].emit (events.js:98:17)
w9ad
2016-02-19 21:02:02+01:00Application exited with code: 8 signal: null
w9ad
2016-02-19 21:02:02+01:00Application process closed with code: 8 signal: null
w9ad
2016-02-19 21:02:04+01:00The container has crashed. A new container will be started to replace it.
xd39
2015-09-16 12:09:18-07:00lorem ipsum dolor set
AUTOSCROLLING
ACTIVITY


#7

It looks like you’re using compose.io for Mongo? If so your MONGO_OPLOG_URL doesn’t quite look right. See Meteor & Compose: a Beginner’s Guide to Using Them Together.


#8

thanks dawg, I’ll have a look


#9

Hi again hwillson :slight_smile: I seemed to have fixed the issues with galaxy, im not getting any errors in my galaxy log anymore - i still can’t seem to view my page tho :confused:

http://sharedvolume.com/

All i get is this : No errors or anything -

any chance you know what’s going on ?


#10

This works:

http://www.sharedvolume.com/

Explanation:

You’ve set the ‘www.’ subomain CNAME to the required one for Galaxy. So that’s what you’ve got to use. All other subdomains, including the naked root domain (without www.), still point to some 184. … IP address (presumably some godaddy webspace server).

If you wanted to use the root domain for your app, I’m not sure if that’s possible using the CNAME setup. I’m not sure if CNAME entries are allowed for the root domain, but I’m sure you could easily try it out if you wanted to.

Cheers


#11

thank you for that :slight_smile: I’ll try and see if I can change the root domain !


#12

Hi Kevin, I’m having the same issue, 502 Bad Gateway. How did you solve it?


#13

Hey :slight_smile: It’s been a while since i’ve had this error ! But if I’m not mistaken, the error was in my settings file !


#14

Is there any mistake in my settings file:
{ “galaxy.meteor.com”:
{ “env”:
{
“ROOT_URL”: “http://www.app.onfiro.com”,
“MONGO_URL”: “mongodb://dbuser:dbpassword@ds01399.mlab.com:1399/shop”,
“MAIL_URL”: “smtp.mail.yahoo.com”,
“isDebug”: “info”
}
}
}


#15

@seeekr - how should the DNS be setup on godaddy if you wanted your root domain to redirect to the www version that we point at galaxy?


#16

@ursamajor Hey, I can’t help you with your problem but I have a question for you :wink: It seems your are using Yahoo Mail to send email from your application I’m wrong ?

My question is, how do you setup your application to use Yahoo to send email ? It’s working ? Even in local ?

Thank’s


#17

Have you tried the usual MAIL_URL syntax of smtp://USERNAME:PASSWORD@smtp.mail.yahoo.com:465/?


#18

@hwillson I try it but when a user complete the registration he should have a verification email but I got this error :
Exception while invoking method 'sendVerificationLink' SenderError: Mail from command failed - 553 From address not verified - see http://help.yahoo.com/l/us/yahoo/mail/original/manage/sendfrom-07.html