When you upgrade to Meteor 2.3+, there is a possibility that you will receive a package constraint error like this:
Errors while initializing project: While selecting package versions: error: Conflict: Constraint email@example.com is not satisfied by accounts-base 2.0.0. Constraints on package "accounts-base": * firstname.lastname@example.org <- top level * accounts-base@~2.0.0 <- top level * email@example.com <- service-configuration 1.1.0 <- accounts-base 2.0.0 * firstname.lastname@example.org <- accounts-password 2.0.0 * email@example.com || 2.0.0 <- matb33:collection-hooks 1.1.0 * firstname.lastname@example.org <- cultofcoders:persistent-session 0.4.5 * email@example.com || 2.0.0 <- apollo 4.1.0
Cause of the error
Accounts package has undergone some major changes including a major version bump
Ask the package author to upgrade his package as indicated in the migration steps in the changelog
If you are maintaining a package that depends on one of the accounts packages which had a major version bump you will either need to set the new version manually or set api.versionsFrom(‘2.3’). You can also have it reference its current version and 2.3 like this: api.versionsFrom([‘1.12’, ‘2.3’]), for specific package it can be like this: api.use(‘firstname.lastname@example.org || 2.0.0’).
If the author of the package is no longer active, the general solution is to fork the package to your
packages folder and update the version constraints yourself as quoted in solution #1 above.
How to fork an atmosphere package?: Writing Atmosphere Packages | Meteor Guide