Installation on windows


#1

I tried installing meteor 1.3 on Windows 10, failed abysmally, tried windows 7 again failed abysmally. I had 1.2 running ok but now I have no Meteor at all as I had to uninstall 1.2 to install 1.3.


Cannot installl on Windows - Pathnames inside .meteor folder are too long
#2

Sorry, the best way to update is to type meteor update in your terminal, rather than reinstalling. But you should be able to install 1.2.1 again with the following steps:

  1. Download the archive from here: https://d3sqy0vbqsdhku.cloudfront.net/packages-bootstrap/1.2.1/meteor-bootstrap-os.windows.x86_32.tar.gz
  2. Follow these directions to install: https://github.com/meteor/meteor/wiki/Meteor-on-Windows:-Alternate-installation

Because of release engineering difficulties, the installer currently doesn’t have a way to select which version is installed.


#3

Thank you Sashko, I thought I must have done something pretty fundamental completely wrong.:slight_smile:


#4

There’s currently a bug with 1.3 and Windows, we’re working on putting out a fix as soon as possible!


Unable to install meteor 1.2.0.1 on windows 8
#5

It’s a minor issue really ,I’ll reinstall 1.2 and update properly. Thanks for your help, Sashko


#6

Having trouble using meteor at all. when I go to app directory - run meteor from cli - hangs after updating to latest “tools” . I’ve observed that uninstalling meteor and running the exe again only completes after the account create/login splash screen.

I suspect that when meteor from cli runs - it starts the update then - expects the “Skip This” mouse input. Hence meteor cli hangs waiting for some mouse click.

I suggest meteor on windows would need to detect it’s run from cli and then ignore the login splash screen or some equivalent behaviour linked to the meteor install exe. Hope this helps solve it - really thinking of running in the cloud instead of laptop - more complex than expected.