IP whitelisting on galaxy seems not to be working

I’m implementing the payment API from lemonway (https://www.lemonway.com/). All the request need to come from whitelisted IPs.

So I switched to Galaxy pro and enabled IP Whitelisting. But it keeps sending the requests from various IPs.

Is there something special that I have to do ?

In case you might have assumed that there would have been a fixed and dedicated address, that’s not the case. Galaxy containers share a pool of ip addresses.

Quoted from http://galaxy-guide.meteor.com/container-environment.html#network-outgoing

To find the IP addresses you should be using, go to your app’s Settings page and copy down the IP addresses shown there

Did you check if those ip addresses match those “various IPs”? If that’s the case, just make sure you’ve whitelisted that bunch and you’re good to go!

In my app settings, it says :

Connections made from your app will come from the following IPs:,,

The three IPs are whitelisted by my payment service. Connection seems to come from other IPs.

Hmm, then I guess you need to contact support :confused:

Did that yesterday ; trying again today.

1 Like