Is * down?

I’m trying to deploy a site right now using meteor deploy on * However, it occasionally times out and I get the following html response in my console:

Simple applications appear to deploy fine:

meteor create new-app
cd new-app

But non-trivial applications fail…

Steps to reproduce:

meteor create --example todos
cd todos
meteor deploy

Here’s the full log when I run meteor logs on

But other people should be able to reproduce from their own accounts

Is there some place to check for downtime?

Have you tried meteor logs to see if there are any errors in your app?

@jorgeer, thanks for the suggestion! It appears you’re onto something because a clean app builds and deploys okay:

meteor create new-app
cd new-app
meteor deploy

At this risk of being that guy who just dumps log messages, here’s a look at what I get when I run meteor logs:

I’m really not sure what that means, but the app is very standard stuff that I’ve deployed tons of times and is working fine locally, so I’m still thinking that something is broken on meteor’s side.

Looks like your accounts-base package (required by one of your account packages) is trying to set indexes for your Meteor.users collection, but isn’t allowed to.

Setting indexes in the mongo database is a very reasonable thing to do though, so I don’t see why this throws an error. You might have found a bug.

This appears to be fixed now:

Might be related: Anybody else seeing Mongo failures on hosted apps?

1 Like

Here’s some background: Anybody else seeing Mongo failures on hosted apps?

1 Like