Meteor 1.4 just released!


#1

Hi everyone,

In case you missed it we just released Meteor 1.4. Type meteor update to update your apps.

A big thank you to everyone who helped out with the release!


#2

I think my app is updating automatically. I never did meteor update, I just ran my meteor npm start script and I’m stuck on

Downloading meteor-tool@1.4.0... with a spinner

UPDATE:

Not sure what happened, but all systems are now go. I repeat all systems are go.


Excited to know that work on Meteor 1.5 has been started
#3

After update, I run the project but it show

➜  loan git:(dev) ✗ meteor
[[[[[ ~/Desktop/meteor-app/loan ]]]]]

=> Started proxy.
=> Started MongoDB.
I20160726-10:43:37.470(7)? { [Error: Cannot find module '../build/Release/bson'] code: 'MODULE_NOT_FOUND' }
W20160726-10:43:37.524(7)? (STDERR) js-bson: Failed to load c++ bson extension, using pure JS version
=> Started your app.

=> App running at: http://localhost:3000/


#4

same for me - I never said update but keep getting Downloading meteor-tool@1.4.0 every time I start meteor.


#5

Hi, please see bson-ext here: https://www.npmjs.com/package/bson-ext

And general info here: https://guide.meteor.com/1.4-migration.html#binary-packages-require-build-toolchain


#7

Are binaries for new package versions supplied? Not everyone in our team has set up a compiler toolchain yet. Is it safe for everyone to update?

The post says binaries of packages need a compiler toolchain but what about the packages that come directly with the release, especially there were issues with bcrypt for example.


#8

From what I heard, packages that come with the release don’t need a compiler and are pre-compiled as usual. The issue is with community packages that have binary code - those need to be precompiled.


#9

Will there be an updated roadmap? @zoltan


#10

Meteor Web-site still offers to download 1.3


#11

Thank you for this release MDG & contributors! Looking forward to 1.5!


#12

Maybe problem with package cfs:gridfs

I20160726-10:43:37.470(7)? { [Error: Cannot find module '../build/Release/bson'] code: 'MODULE_NOT_FOUND' }
W20160726-10:43:37.524(7)? (STDERR) js-bson: Failed to load c++ bson extension, using pure JS version

Please help.


#13

If console welcomes me with “exit code 3” instead of meteor start - MDG released the newest update…
I suppose 1.4 is not compatible yet with MUP, and would clearly require docker reconfig?
Also, quite troublesome database migration… Why does this version even pass as auto-update?


#14

You don’t have to migrate a single thing in the database…?


#15

Meteor downloads the update in background, so that when you enter meteor update or meteor create, it’s using the latest recommended release.


#16

How can I specify a python version when running meteor update inside a meteor project?

I am getting the following error:

=> Errors while initializing project:                                              
                                              
While downloading npm-bcrypt@0.8.7...:
error: Command failed:
/Users/charles/.meteor/packages/meteor-tool/.1.4.0.fhn7fv++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/bin/npm
rebuild --no-bin-links --update-binary
gyp ERR! configure error 
gyp ERR! stack Error: Python executable "/Users/charles/anaconda/bin/python" is v3.4.4,
which is not supported by gyp.
gyp ERR! stack You can pass the --python switch to point to Python >= v2.5.0 & < 3.0.0.
gyp ERR! stack     at failPythonVersion

Edit – looks like I can just use anaconda to switch to python 2.7:

$ conda create --name meteor python=2.7
$ source activate meteor
$ meteor update

#17

i try to install meteor in a server (gce), but when use meteor create myapp i stuck whit a error. how can solve this?


#18

Now that we have Mongo 3.0+, you can use queryPlanner on your local box easily. I made a video showing how it works: https://www.youtube.com/watch?v=z9-9PCaEpbU


#19

Yes @nickgudumac , expect an updated roadmap shortly.


Code splitting with reify
#20

#21

Deployment is broken it seems with 1.4 so I have to revert to 1.3 for now