Meteor 1.5 Windows 10 x64 crash immediately

So, I decided to upgrade to 1.5 and see how my application is working with the new version. Ran through the meteor update command and that completed with no issues. Tried to start the application using my standard meteor --settings settings.json command. It builds and then crashes continually with the following:

20170606-10:21:09.418(-5)? Reading 'versions' file...
20170606-10:21:09.493(-5)? (STDERR) C:\Users\myuser\AppData\Local\.meteor\packages\meteor-tool\1.5.0\\dev_bundle\server-lib\node_modules\fibers\future.js:280
20170606-10:21:09.495(-5)? (STDERR)                                            throw(ex);
20170606-10:21:09.497(-5)? (STDERR)                                            ^
20170606-10:21:09.497(-5)? (STDERR)
20170606-10:21:09.498(-5)? (STDERR) Error: ENOENT: no such file or directory, open 'C:\Users\myuser\meteor\\.meteor\local\build\programs\server\.meteor\versions'
20170606-10:21:09.500(-5)? (STDERR)     at Error (native)
20170606-10:21:09.501(-5)? (STDERR)     at Object.fs.openSync (fs.js:549:18)
20170606-10:21:09.504(-5)? (STDERR)     at Object.fs.readFileSync (fs.js:397:15)
20170606-10:21:09.505(-5)? (STDERR)     at meteorInstall.meteordeps.js (meteordeps.js:11:19)
20170606-10:21:09.505(-5)? (STDERR)     at fileEvaluate (packages\modules-runtime.js:333:9)
20170606-10:21:09.506(-5)? (STDERR)     at require (packages\modules-runtime.js:228:16)
20170606-10:21:09.507(-5)? (STDERR)     at C:\Users\myuser\meteor\\.meteor\local\build\programs\server\app\app.js:20295:1
W20170606-10:21:09.508(-5)? (STDERR)     at C:\Users\myuser\meteor\\.meteor\local\build\programs\server\boot.js:338:34
20170606-10:21:09.510(-5)? (STDERR)     at Array.forEach (native)
20170606-10:21:09.511(-5)? (STDERR)     at Function._.each._.forEach (C:\Users\myuser\AppData\Local\.meteor\packages\meteor-tool\1.5.0\\dev_bundle\server-lib\node_modules\underscore\underscore.js:79:11)

Please some “fix” other than the standard meteor reset which WIPES the entire database that we have worked to create to have a “small” clone of our live environment. Cannot post the app, too proprietary. It has had no changes since it was working pre-update.

You can reset your app while retaining the database. All you need to do is go into the C:\Users\myuser\meteor\\.meteor\local\`` directory and delete *anything but* thedb` directory.

Also, it might help to uninstall and completely remove meteor from your system (delete your local data, caches, registry entries etc) and then start with a fresh install of Meteor 1.5 using the installer.

I have tried the following steps:

  1. Uninstalled the current meteor installation from control panel
  2. Deleted %LOCALAPPDAATA%/.meteor folder completely
  3. Removed all but db directory in .meteor\local for the application
  4. Restarted system for good measure
  5. Reinstalled meteor from download obtained today
  6. Restarted system again.
  7. Started application using same options from above

Same exact problem ‘Reading ‘versions’ file…’ with continual crashing until it shows waiting for file change. Will probably have to revert back to the 1.4.x line until it can be stabilized. Development needs to continue and this has already consumed a good part of the day. Disappointing…

The question is: Does this also happen when you try to start a fresh Meteor 1.5 project?

Ok, I feel pretty dumb now, but want to save others potentially from having this issue in the future. After upgrading to 1.5 there were some packages that would not upgrade because of dependency issues. After a bit of searching around I came to this:

I forgot to remove from my folder before build and this was root of the issue. Now onto actually testing 1.5, sorry for the wasted time. Thanks all for the responses.

1 Like

Ah, nifty!

Btw, instead of removing it before a build, you can simply wrap the code block in an if ( Meteor.isDevelopment ) { /**/ } which would ensure that the code only tries to execute during development.

Just renamed it meteordeps.NOTjs :slight_smile: It is something that you just run standalone from the shell.

1 Like