Meteor hanging at 'starting your app' / patch

The day has come that Meteor suddenly didn’t work…

=> Started proxy.
=> A patch (Meteor for your current release is available!
   Update this project now with 'meteor update --patch'.
   Starting your app

Hangs forever and ever and ever…

So I tried to install the patch

 meteor update --patch
Unable to update package catalog (are you offline?)

If you are using Meteor behind a proxy, set HTTP_PROXY and HTTPS_PROXY environment variables or see this page for more details:

Sorry, Meteor is not installed and could not be downloaded. Please check to make sure that you are online.

Yeah, sure I’m offline. That’s why I’m able to post this :slight_smile:
Checking All systems are operational…uhmmmmm

Nothing changed from my site today. What’s going on Meteor / @sashko?

Running Meteor works again for me. Patch still hangs.

Similar problem here. Hangs forever showing this:

Downloading meteor-tool@1.4.2_5… /

Control C doesn’t work either, had to killall -9 node on a different terminal.

I don’t want even try ((((-:


A couple of questions:

Is it an optional patch?

Where can we find release notes?


1 Like

Mine seemed to hang too for at least 30 mins (the spinning ‘/’ stopped spinning) and the CPU went right down. However the next time I checked it had completed ok.

You can generally get some information on the Meteor github page:

It says:


Reverted #8213 as the change was deemed too significant for this release.
Note: The decision to revert the above change was made late in the Meteor release process, before it was ever recommended but too late in the process to avoid the additional increment of the version number. See #8311 for additional information. This change will still be released in an upcoming version of Meteor with a more seamless upgrade.

Doesn’t sound like an essential update!

What I don’t understand, why does meteor need to call home in order to start?

This means that when the Meteor server is down / unreachable, your application cannot start and devs cannot work. Imo calling home should be non-blocking.

It worked with no issues for me. I think it can sense fear … :wink:

1 Like

Is anyone else having issues deploying to Galaxy with this most recent patch?

@Siyfion Yes, we deployed code using to Galaxy and it caused build errors around the future.js file. Dropping back to solved the problem. I’ve raised it as an issue.

Ah good, nice to know I’m not the only one with this issue.

Meteor still starts just fine if it can’t reach the package server by the way. This must be something else.

Are people still seeing this? It’s possible there were some issues with the package server around the time that these were reported.

If you are still seeing this: does meteor refresh work? How about meteor update --release

meteor update --release did the trick for me. Thanks.

1 Like

I’m inclined to believe that this must be related to a (temporary?) connectivity issue with the package server. We certainly updated a number of applications to Meteor before officially recommending it and didn’t encounter any problems.

Things to remember:

  • If your proxy blocks websockets, this could cause a problem as Meteor uses its DDP protocol to speak with the package server to find information about upgrades. Check your WebSocket abilities by going to this site and pressing the “Connect” button. You should see a message which says “CONNECTED” in the “Log”.
  • The meteor-tool is over 100MB so Downloading can actually take some time if you’re on a slow connection
  • If you’re getting Unable to update package catalog adding the --verbose flag to the meteor update command could provide additional information about why the connection failed.
  • If you’re getting anything besides Unable to update package catalog, please give the specific output of your error where possible!

@oliverlloyd It sounds like you’re definitely experiencing a different error than this issue was originally referring to? See my last bullet point above.

@Siyfion Are you getting the message originally reported in this thread or something else entirely?

I’m just a tad annoyed that the fix for the Windows10 Powershell bug I committed did not make it into this release.

You guys do realize that the latest version of Visual Code has Powershell as its default terminal, instead of Cmd?

I noticed that was taking an inordinate amount of time to update (I killed and restarted it a couple of times). Then while it was downloading I took a look at the task manager and was reminded that on Windows the antimalware process swamps the CPU and slows the extraction of the data considerably.

See issue here.

Finally, I just waited ~20 min and it all worked out.

Meteor Update Tip: as an optimization…

I recommend doing a meteor create newproject as a way to install the new builds. It is a minimum project and it is mostly about installing the new version of meteor on my machine. I have never had a problem installing new versions when I do it for a new project.

I have found in the past that doing a meteor update on my larger projects before meteor-tool is loaded on my machine can get a little tangled up and throw weird errors that turn out to not be true.


@abernix You’re right, mine and (I’m pretty sure) @Siyfion’s problems are different to the one this thread concerns. Separate issue raised here.

If this is an approach that you want to take, another option would be to just run meteor --release <new-version-number> --help, which in the same manner, will actually ONLY install the new version of the meteor-tool on your machine and not make any changes to the project itself. :slight_smile:

1 Like