Meteor not recognized as internal or external command on Windows 7


#1

I had Meteor running on a Windows 7 machine. I uinstalled NodeJS and then reinstalled it. Unfortunately, after I reinstalled it meteor no long works. That is to say when I type “meteor” on the command line, it responds with:

‘meteor’ is not recognized as an internal or external command, operable program or batch file.

I uninstalled and reinstalled meteor rebooting between steps, but still no avail. I checked another machine and found that it installs itself to c:\users<user>\AppData\Local.meteor this directory is not found after at the install on the problem machine.

How can I get meteor back?


'meteor' is not recognized as an internal or external command
#2

This turned out to be a problem with the PATH variable. One item in the path didn’t have a closing double quote. Once I fixed that issue and reinstalled meteor the issue was resolved.


#3

How do they have to look like? I changed my variable, too and now it doesn’t work anymore, what do I have to do to make it work again?


#4

Got it, I just gave it the path to the meteor folder that was created with the first installation


#5

hello i got same issue please check screen shot.

meteor is not recognized as an internal or external command, operable program or batch file


#6

Hi all, just signing up to say I too am getting this. Windows 7 64bit.

I run the installer, I create (or log in to) my account and almost instantly I get shown the “Meteor is installed” page “Open up a command prompt” etc etc. But as it stands the meteor command is not recognised.

I see no mention of meteor in the PATH env and if I search my computer for “meteor” I see no related files.

I’m not getting any form of error message / log (as far as I can tell!).

Does the installer run off and grab more files? The office I am working from has quite a strict firewall in place. If the installer does go and get files can I have a domain / location that I can have the network admins whitelist?

As a side note, as this is a problem I’ve had with other programs (e.g. cordova at one point) my windows username is “forename surname” so the user directory is C:\Users\Forename Surname\ and this space caused issues with command line tools

Thanks
-Chris


#7

Try adding %USERPROFILE%\AppData\Local\.meteor; to your PATH.

If your system path doesn’t work, try the user path.


#8

Bingo! That’s it! Not sure when windows search didn’t find it, but your fix worked, so thank you very much!